Benbox Laser Machines/CO2 Lasers/3D Printers

Software => T2 Engraving => Topic started by: Jym on November 24, 2019, 02:53:21 AM

Title: T2 and Laserbot
Post by: Jym on November 24, 2019, 02:53:21 AM
Hello

I have T2 in trial mode.
What firmware can i use with laserbot ( megapi) .
Actually i use bencutlaser  (trial too) and this is good.

Thank you
Title: Re: T2 and Laserbot
Post by: Zax on November 24, 2019, 04:34:46 AM
If you already have firmware installed and the machine is working, then you don't need to change it. You may need to Send Default Parameters from the Machine menu or Display Grbl Parameters and compare your settings to my defaults.
Title: Re: T2 and Laserbot
Post by: Jym on November 24, 2019, 06:31:48 AM
Yes, but with firmware 1.1f mega 2560, laser is always on. No motor action.
Title: Re: T2 and Laserbot
Post by: Zax on November 24, 2019, 06:41:12 AM
Are you saying the machine works correctly with other software and not T2Laser?

T2Laser sends G-code, so it should be the same with any software. If the laser is always on and the motors aren't working it sounds like a problem with your machine / firmware and not software.
Title: Re: T2 and Laserbot
Post by: Jym on November 24, 2019, 07:00:27 AM
Ok,
Laserbot is ok with Mlaser and firmware integrated in Mlaser
Laserbot is ok with Bencutlaser and firmware Marlin 110 RC8 FA BL

But not working with T2.
I think this is not T2 of course, but the parameters and/or firmware.
Title: Re: T2 and Laserbot
Post by: Zax on November 24, 2019, 12:20:25 PM
Did you select Mega in the Settings / Microprocessor menu (on the Laser Controller screen)?