Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - CaseyP

Pages: [1] 2
1
T2 Engraving / Re: Position
« on: December 16, 2019, 09:50:18 PM »
This was a problem I had when I was starting as well.  The canvas size should be the area you want to work in, and the trace outline will outline that canvas size. 

You can move the laser around with the up down left right buttons on the T2 control panel, and just set the laser power really low (like 25) and turn on the laser, so see where it's located. 

Once you have it where you want your bottom left to be, right-click the home icon in the middle of the direction buttons.   That will re-set the coordinates to 0,0, and that will become your new bottom left (assuming you are starting from bottom left.)

2
T2 Engraving / Re: Multipass on DXF file?
« on: September 02, 2019, 06:40:57 AM »
Thanks Zax,

I got the color thing sorted, I found the Inkscape Palette you created and used those colors.

I was able to successfully use Cut and Engrave mode, and have the black outline get 6 passes, while the engraved area only got one. 

That was exactly what I wanted.


Now the only problem is, the engraved area in green came out very faint compared to previous test, where the only thing all got 1 pass only.

Could it be because of the green, and T2 is using lower laser power?

Is there a way to customize those settings or disable them for Cut and Engrave mode?

3
T2 Engraving / Re: Multipass on DXF file?
« on: September 01, 2019, 10:32:00 PM »
Well, I guess I spoke too soon. 

I was able to figure out the file in SVG format, but then as soon as I turn it into DXF, I lose all of the color coding, and get a huge blob of black stroke outline across all the engraving. 

I'm not sure why DXF loses the colors, but that makes the Cut and Engrave option not really viable. 

I feel like I'm grossly overcomplicating this.   I just want to do some vector clipart and text, and then cut out a rectangle around the material on 1.8mm leather.

I'll attach the files below in case I am missing something simple.  Basically I just want the vector lines to be green in the DXF file, and not black thick stroke lines.   

This is the same file pre and post DXF conversion.


Thanks in advance for any help.


4
T2 Engraving / Re: Multipass on DXF file?
« on: August 31, 2019, 01:57:04 PM »
I figured out how to change the colors in Inkscape, so I can use the Cut and Engrave mode that you mentioned :)

For any future users with the same question:

Hit Ctrl Shift W in inkscape to bring up the Swatch tool, select a vector path and click on a color from the bottom menu.

Hopefully tonight I can test this new file after I get off work.

5
T2 Engraving / Re: Multipass on DXF file?
« on: August 31, 2019, 11:51:32 AM »
Great, thank you.

I am using inkscape, and I didn't even know I could assign colors in that program.   I'll set the engrave only items to a color and the rest I'll leave black.


Is there a way to color certain lines / objects in T2? 

Appreciate the help again this week.

6
T2 Engraving / Multipass on DXF file?
« on: August 31, 2019, 10:08:48 AM »
Hello all,

I am trying to make some small tags for my mom, and it is essentially some clipart and text on a piece of leather.

I would like the image and text to just get 1 or 2 passes, or a slower pass, for example,

Then the edges and some circle (holes for thread) to get multipasses and be cut free. 

Essentially the sketch Plus (Overlay) function,  but it doesn't seem to work on a DXF import.

I hit AutoTrace, and click outside the art, but nothing turns red. 

I would also like to set up the colors = cutting speed fuctionality, but I have no idea how to adjust those settings and assign a color.

Thanks all. 

I'll attach images once I get to work and can dig them out of gmail.

7
T2 Engraving / Re: Laser runs off the side
« on: August 29, 2019, 09:37:02 AM »
great, thanks!

I've gone into the advanced sections and told the machine 80 steps per mm, and now that I am using the right sizes, everything seems right.

I also saw a youtube video showing me how to preview the frame and that really helps with surprises in size and spacing. 

I really feel like I have a good idea what is going to happen when I press play, now.

I am doing a test engraving right now for the grey scale and a flower that I manually sized. 

The tests are already pre-sized, so they always worked great.   It was everything else that was wonky.   

But now I am 3-4 tests in with predictable results, and I feel like I can actually test in a controlled manner, and predict the results.

Thank you all so much!

8
T2 Engraving / Re: Laser runs off the side
« on: August 27, 2019, 09:06:58 PM »
Thanks Loki,

but I have no idea how to get T2 to measure my workspace like that.

I've watched the Youtube videos for T2 and I've read the introduction thread that covers its features, etc.


9
T2 Engraving / Re: Laser runs off the side
« on: August 24, 2019, 03:01:17 PM »
oh wow!

okay that makes a world of difference.   

Is it accepting measurements in mm?  so the 300 x 400 is showing mm of work space?

10
T2 Engraving / Re: Laser runs off the side
« on: August 24, 2019, 01:09:07 PM »
I think so? 

I told the machine to update firmware to 1.1e, which was its own button.  Nothing happened so I assume it's up to date.

Zax: the machine chose 300x400 when I told it I had the A3.  I don't think I have home switches.

How do I set the canvas size to my material, vs the output image size?

11
T2 Engraving / Re: Laser runs off the side
« on: August 24, 2019, 09:11:21 AM »
okay, I found the post that answers those questions, let me grab those screenshots right fast...


So measuring the work area, it's 422mm tall x 466 mm wide.   I am assuming the x axis is the wider side, but in my settings I've had to invert X and Y to get them to move predictably.

I calibrated the steps per mm and my 10mm square test came out properly.

Here are the gmbl parameters:

Sending...
Complete (13 lines in 1 seconds)
$0=10 Step pulse, microseconds (10)
$1=25 Step idle delay, milliseconds (25)
$2=0 Step port invert, mask (0)
$3=2 Direction port invert, mask (0)
$4=0 Step enable invert, boolean (0)
$5=0 Limit pins invert, boolean (0)
$6=0 Probe pin invert, boolean (0)
$10=3 Status report, mask (1)
$11=0.020 Junction deviation, mm (0.020)
$12=0.020 Arc tolerance, mm (0.020)
$13=0 Report inches, boolean (0)
$20=0 Soft limits, boolean (0)
$21=0 Hard limits, boolean (0)
$22=0 Homing cycle, boolean (0)
$23=3 Homing dir invert, mask (0)
$24=100.000 Homing feed, mm/min (100.000)
$25=1000.000 Homing seek, mm/min (1000.000)
$26=250 Homing debounce, milliseconds (250)
$27=1.000 Homing pull-off, mm (1.000)
$30=255 Max spindle speed, RPM (255)
$31=0 Min spindle speed, RPM (0)
$32=1 Laser mode, boolean (1)
$100=80.000 X steps/mm (80.000)
$101=80.000 Y steps/mm (80.000)
$102=80.000 Z steps/mm (80.000)
$110=5000.000 X Max rate, mm/min (5000.000)
$111=5000.000 Y Max rate, mm/min (5000.000)
$112=5000.000 Z Max rate, mm/min (5000.000)
$120=800.000 X Acceleration, mm/sec^2 (800.000)
$121=800.000 Y Acceleration, mm/sec^2 (800.000)
$122=5000.000 Z Acceleration, mm/sec^2 (5000.000)
$130=400.000 X Max travel, mm (400)
$131=300.000 Y Max travel, mm (300)
$132=200.000 Z Max travel, mm (200)

I've been following various threads and guides and video series, always finding one more setting that I haven't properly configured over the last year or so.

Hopefully I'm getting close now...

I really appreciate the attention people put into these forums, hanging around for us newbies, once their own machine works perfectly fine.

12
T2 Engraving / Re: Laser runs off the side
« on: August 24, 2019, 09:00:04 AM »
Thanks for the replies,

I am working in T2 laser but I haven't been able to find the grbl parameters, is there a menu function to display those?

I know I read this on these forums a few days ago but I can't find the right thread...

@Zax:  Yeah I'm not sure what I'm missing either.   I'm going to grab a tape measure and physically measure the work area.   Does the 300x400 refer to mm for the work size?

Thanks again


13
T2 Engraving / Laser runs off the side
« on: August 23, 2019, 04:10:09 PM »
Hello again all. 


I've had t2 laser for a few years now but I'm still a newish engraver.


The biggest issue that has kept us from really engraving is the laser running off the engraving area, and the motors grind against the strap, trying to keep going.

I have the eleksmaker a3, which t2 identifies as a 300x 400 work area.


However something else must be wrong because the laser still tries.

I would like to set the laser at the lower left of the art work, not the canvas, so I can start the project where the work is going to be.


I have set the origin 0,0 where the laser is at, set the lower left as the origin in settings, hit start for the small test square, and zoom it goes off the grid.    I hit the emergency stop before it can damage my motors.



Any help finally solving this would be greatly appreciated.   I will measure the actual workspace and go through the adjustments tab and check on the 80 steps per mm default once I'm off work.


Texting from a cellphone, please forgive the brevity.

14
T2 Engraving / Re: Staining wood
« on: December 24, 2017, 05:38:29 PM »
Great, thank you both! 

I have stain with poly mixed in, so I will lower laser power for those jobs. 

Really appreciate the help!

15
T2 Engraving / Staining wood
« on: December 22, 2017, 01:15:08 PM »
Hello all. 

I've been pumping out Christmas gifts with my laser and I really owe it to the help I've received from everyone here.  Thanks for that!

I was wondering if we could finish off the wood with stain before the engraving in order to get more contrast, and also how to seal off the wood post engraving? 

I am thinking probably clear polycoat?

So far everything I've done has been left raw.   

I just did some leather cutting, and then sealed it with Leather Waterproofing spray (for tennis shoes).   Made me curious.

Pages: [1] 2