Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Administrator

Pages: 1 [2] 3 4 ... 11
16
I am in the process of modifying my BenCutLaser (BCL) software to support the Smoothie controller board that can be used in a 40 watt (or higher) CO2 Laser Machine. I am presently about 90% finished.

Some very useful links from the Smoothie website:

The step by step instructions on what to do to convert your CO2 laser over to using a Smoothie controller board. Very detailed instructions: http://smoothieware.org/laser-cutter-guide

If your laser machine has two stepper motors driving the Y axis and your Smoothie board is the one that only has one Y (M2) driver plug, you're going to need to use a Splitter cable. Instructions on how to drive two steppers from one plug is here: http://smoothieware.org/general-appendixes

Supported G-code commands: http://smoothieware.org/supported-g-codes

Making the move from Grbl to Smoothie: http://smoothieware.org/from-grbl
Your interaction with your CO2 laser machine is different than it is with a low powered laser diode machine. The commands to set the various Grbl values are different for the Smoothie and this link provides a list for all of them.

GRBL....Smoothie........................Action
$..........help................................Display help
$$........cat /sd/config.................Display current configuration
$#........M114 M114.1 M114.2....Display current positions
$I.........version..........................Display build info
$X........M999.............................Exit alarm mode
$H.......$H..................................Run homing cycle

You can send these Smoothie commands inside BCL from any one of the four g-code windows.

In BCL version 2.0 (not released yet) type in, for example, version and make sure the cursor is on that line and press the F5 key to send that command to the Smoothie controller board. Smoothie will return the version information in the com port receive window.

17
General Discussion / Correct Belt Tension Video
« on: May 26, 2017, 09:46:32 PM »
I was asked to make a video to visually show how to determine the correct belt tension using your finger.

Here it is: https://www.youtube.com/watch?v=yAFyZZX8RUk

18
Benbox / Benbox Software Security Risk
« on: May 04, 2017, 05:33:18 AM »
One of our forum members, @mic159, sent me the following information regarding the security risk he found in the default China factory Benbox software program.

@mic159 says the following about this software:

"Its not a virus, but the software has some holes in it that can be used by bad actors to do bad things.

The Trojan warnings are definitely true, but again, it was probably not intentional, just bad design of an auto-update feature.

I would definitely never install this software outside of a virtual machine!

I would suggest deleting curl.exe from the installed directory to disable the auto-updater/trojan part of it.

I would also suggest not browsing the internet while running the software.

In addition to deleting curl.exe, also delete update.dll. I just checked and it all still works.

Deleting the files will only deactivate the Trojan side, not the other issue."

19
General Discussion / EleksDraw and EleksEgg new software boards
« on: April 30, 2017, 08:00:39 AM »
At the suggestion of @Zax, I've added two new software boards to our forum:

EleksDraw and EleksEgg.

20
So, my side project is coming along, but I've hit a snag with the Z axis stepper motors.

I'm converting my Prusa i3 3D Printer over to a laser machine because I want to try out the Z axis stepper motors to allow cutting of thicker woods.

I've got the two Z stepper motors working using a spare EleksMaker L6 controller board, running Grbl 1.1e.

I'm running both Z steppers from one Z axis port on the controller board (see attachment). I have the wires soldered such that the one Z port is driving both Z steppers. This scheme seems to be working fine.

The steppers for the X and Y axis work fine and they are belt driven. The two Z axis steppers turn long screws, vertically, which sends a Z axis gantry up or down.

I send a g-code Z distance of 50mm but the Z motors turn enough to maybe move the Z axis up 5mm or so. I've tried a lot of different Grbl $102= values, but after I set it, it works for the first time only. After the first time, the Z axis only moves about 10% of what distance was commanded. I don't understand what is causing that behavior. I'm also not sure what Grbl adjustments I need to make to get the two Z steppers to move the distance commanded by the g-code.

I suspect that the problem has something to do with the Z steppers driving axial jack screws instead of belts. So I don't know if I need to change the step values from 1/8 or 1/16 to something else. However, with this L6 board I don't think I have the ability to make that kind of change. So maybe the L6 is the wrong board to be using?

So if I set $102=160 and try to jog 10mm, it will jog 10mm the first time after setting =160. If I jog again, it jogs maybe 1mm. If I set $102=80 and try to jog 10mm, it will jog 10mm that first time after the setting. If I jog again, it jogs maybe 1mm.

I'm thinking that maybe I need a different controller board? I have an EleksMaker IV Axis CNC board on order from Banggood but I'm not sure that will fix this problem. I think the problem has something to do with the fact that the two Z axis steppers are axial driven motors while the X and Y steppers drive belts.

The motors and frame are from FolgerTech and it is the prusa i3 clear acrylic frame.

Any help appreciated. Thank you.

21
BenCutLaser / Need engraving files (RESOLVED)
« on: April 16, 2017, 02:27:00 PM »
Paul and I are in the final stages of testing BCL Engraving. I'd like to test some of the images you folks have an interest in engraving to make sure BCL can handle them.

Please email them to me or attach them to this thread.

And let me know if they should be done in B&W or Gray Scale (GS).

Thanks...

22
EleksMaker IV Axis / "A Motor" Port Slaving?
« on: April 10, 2017, 10:16:31 AM »
On the 'EleksMaker IV Axis' controller board, does anyone know how to slave a Z stepper motor plugged into the 'A Motor' port, with the primary Z axis stepper motor plugged into the normal 'Z Motor' port?

I want to run and control two Z axis stepper motors.

Is this done with a jumper on the board?

23
General Discussion / 3D Printer Repair Thyself
« on: March 31, 2017, 03:04:58 PM »
Attachment shows a replacement part I'm printing for my printer  :)

24
General Discussion / USB Cables and Belts
« on: March 30, 2017, 05:57:59 PM »
I had too many USB cables laying all over my work tables and spare belts hanging up in other rooms...so I finally put up a central 'hanger' to hang them all on. Believe it or not, I had to order 6 more USB cables from Amazon last night.

As it turned out, today, I had to use two of my spare Nano's. That leaves me with about 4 spares left. Might be time to order some more Nano's as well  :)

The second photo is my new work area...3D printer on the left side and laser machine on the right side. You can see the two window fans that suck the laser smoke out the window. Works very well as I just had the laserBot there doing some lasering yesterday and the smoke exhausted out nicely.

The water bottle is just visible on the right side of the picture...there are two fire extinguishers just to the right of the water bottle...I have never had to use either one...yet...knock on wood...!!!

25
BenCutLaser / Images coming to BCL (OPEN)
« on: March 28, 2017, 08:57:13 AM »
Paul has been hard at work on adding image capabilities to BCL.

Attachment shows his work in progress.

Coming soon...!!!

27
General Discussion / MOVED: FAQ - my motors don't move
« on: March 13, 2017, 07:53:05 PM »

28
Folgertech / Slow customer service
« on: March 10, 2017, 08:02:51 PM »
I've had my Folgertech 3D Printer now for about a year. The hot bed stopped working recently and I'm trouble shooting it to find out what failed.

I sent a support email to Folgertech and was disappointed it took 2 days to get a response. I had to ask a question in response to their email and so far, another whole day has passed, without a reply to my reply.

I don't know what has happened to their customer service but it's really slow now. I'd have to think hard and long about buying another major system from them. Having to wait 2 days for a support response is unsat in my book!

They have a phone number, which I called, but it is only a pre-recorded message with no human at the other end. Bad. really bad.

30
FAQs For New Users / T2Laser Help
« on: March 09, 2017, 12:37:56 PM »
In T2Laser press Shift-F1 or click Help / Manual.

It will open a searchable help file which has a Troubleshooting / FAQ section.

Pages: 1 [2] 3 4 ... 11