Author Topic: Xaxis Offset When Going Into Controller Window  (Read 124 times)

ScottV

  • Newbie
  • *
  • Posts: 4
    • View Profile
Xaxis Offset When Going Into Controller Window
« on: August 31, 2017, 02:28:12 PM »
Good Day,

I have an annoying issue.  Every time I go into the laser control window from the general setting/graphics window, the x axis gets offset by -0.9 (see picture).  This happens even if I have it previously set to the 0,0 point I want or last used if I'm doing a repeated operation.  Its simple to fix by right clicking the home icon to re-zero it all but is there a way to have it not always set the x axis to this arbitrary -0.9?


Scott Vickers

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4806
    • View Profile
    • T2Laser
Re: Xaxis Offset When Going Into Controller Window
« Reply #1 on: August 31, 2017, 02:45:39 PM »
You've accidentally set an offset, probably by clicking machine home instead of workpiece home.

It's easy to fix, in the Machine menu click Clear Grbl Positions.

ScottV

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Xaxis Offset When Going Into Controller Window
« Reply #2 on: September 01, 2017, 04:13:59 PM »
Thank you for that.  I don't know how that got in there and I thought I had looked at everything to fix it.

As usual the simplest things right in front of you are the hardest to see.

Thanks,

Scott

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4806
    • View Profile
    • T2Laser
Re: Xaxis Offset When Going Into Controller Window
« Reply #3 on: September 01, 2017, 04:46:45 PM »
Add home switches and you'll always have a true position (not based on where you connect) and can set preset locations.

It's an easy update, just add 2 microswitches (one for each axis at front left) connected in parallel between D9 and GND. Then enable in the menu and you'll get a red home icon to indicate it's a real home operation.