Author Topic: Power not increasing on laser when g code sent  (Read 3140 times)

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4584
    • View Profile
    • T2Laser
Re: Power not increasing on laser when g code sent
« Reply #30 on: December 12, 2016, 02:47:27 PM »
The DIP switches set the microstepping mode for the motors, most are hardwired to 1/16.

lenjsr

  • Newbie
  • *
  • Posts: 35
    • View Profile
Re: Power not increasing on laser when g code sent
« Reply #31 on: December 12, 2016, 03:38:36 PM »
thanks

lenjsr

  • Newbie
  • *
  • Posts: 35
    • View Profile
Re: Power not increasing on laser when g code sent
« Reply #32 on: December 12, 2016, 04:01:17 PM »
ok update , I reflased the nanao with the software that came with machine, followed a set up video I found on line using benbox . It worked fine except the burn is backwards. any help here with benbox software. tried t2 laser worked great also but still backwards
« Last Edit: December 12, 2016, 04:03:11 PM by lenjsr »

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4584
    • View Profile
    • T2Laser
Re: Power not increasing on laser when g code sent
« Reply #33 on: December 12, 2016, 04:08:27 PM »
Was the firmware the standard Benbox one, something like: LX-Nano.328p.20150626.hex?

I don't think you can reverse the axis with the Benbox firmware, so you'd have to change the motor wiring.

See what it does with T2Laser now, if it is Benbox firmware it will still work (although not all functions are available).

If I know the required pinout for your machine it is simple to compile a 1.1e hex so you can use T2Laser, if you are interested.

Also, one more question. Did you try the 0.9j custom firmware?

lenjsr

  • Newbie
  • *
  • Posts: 35
    • View Profile
Re: Power not increasing on laser when g code sent
« Reply #34 on: December 12, 2016, 04:21:56 PM »
ZAX thanks, I am not sure what you mean by
If I know the required pinout for your machine it is simple to compile a 1.1e hex so you can use T2Laser, if you are interested.

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4584
    • View Profile
    • T2Laser
Re: Power not increasing on laser when g code sent
« Reply #35 on: December 12, 2016, 04:25:41 PM »
I can provide a custom version of the Grbl firmware that will work with your configuration, but need to understand what pins on the Nano connect to your motors and laser.

When you used the 1.1c firmware did everything work except the laser?

Knowing what firmware you are using now will help me understand how your machine is wired.

lenjsr

  • Newbie
  • *
  • Posts: 35
    • View Profile
Re: Power not increasing on laser when g code sent
« Reply #36 on: December 12, 2016, 04:43:59 PM »
I cant remember I tried so many things . I will reflash the 1.c and see soon and let you know

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4584
    • View Profile
    • T2Laser
Re: Power not increasing on laser when g code sent
« Reply #37 on: December 12, 2016, 04:55:39 PM »
If you wouldn't mind, after testing 1.1c see if the 0.9j (custom) works.

lenjsr

  • Newbie
  • *
  • Posts: 35
    • View Profile
Re: Power not increasing on laser when g code sent
« Reply #38 on: December 13, 2016, 11:29:16 AM »
Ok here is the results of the 1.1c  with t2 lase moves great no laser power, ben box nothing

with .9 custom t2 moves great no laser power, ben box nothing

both flashed from t2 laser machine tab. I DO NOT have the 1.1c and 9 Custom files on my PC so I can try to flash in the benbox software

hope this makes sense
« Last Edit: December 13, 2016, 11:31:56 AM by lenjsr »

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4584
    • View Profile
    • T2Laser
Re: Power not increasing on laser when g code sent
« Reply #39 on: December 13, 2016, 12:03:40 PM »
I appreciate you taking the time to check that out.

Now we know your machine setup:
X STEP  D2
Y STEP  D3
X DIRECTION  D5
Y DIRECTION  D6
LASER D12 (no PWM)

So everything is standard except you can't change the laser to D11.

I compiled a hex with your configuration and posted it here:
http://benboxlaser.us/index.php?action=dlattach;topic=50.0;attach=4825

You can install it using XLoader (what most people use) or possibly with Benbox although I haven't tried that.

FYI: The hex files are provided in the T2Laser zip and also copied to the install folder, but it doesn't matter how they get flashed since all programs use the same method.

lenjsr

  • Newbie
  • *
  • Posts: 35
    • View Profile
Re: Power not increasing on laser when g code sent
« Reply #40 on: December 13, 2016, 12:16:39 PM »
I switched the plugs on the board and solved the backwards problem using Benbox, but where do we go from here

I want to use my t2 laser software also I will flash the file u supplied and let u know
« Last Edit: December 13, 2016, 12:19:34 PM by lenjsr »

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4584
    • View Profile
    • T2Laser
Re: Power not increasing on laser when g code sent
« Reply #41 on: December 13, 2016, 12:18:31 PM »
See the edit I just made, you can give Grbl 1.1e a try and if it needs any axis reversing it can be done from the menu in T2Laser. You machine won't support PWM / grey scale but you'll be able to use any software you choose.

lenjsr

  • Newbie
  • *
  • Posts: 35
    • View Profile
Re: Power not increasing on laser when g code sent
« Reply #42 on: December 13, 2016, 12:52:34 PM »
should I flash the 1.1 in the software ?????? or is the file above


I flashed the file you sent works great with t2 laser . No in benbox, still backward in t2, tried all the axsis reverses
« Last Edit: December 13, 2016, 12:55:04 PM by lenjsr »

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4584
    • View Profile
    • T2Laser
Re: Power not increasing on laser when g code sent
« Reply #43 on: December 13, 2016, 01:15:36 PM »
You flashed "grbl_11e_nopwm.hex" from the link above?

The axis reverse functions should work correctly as they invert the direction mask, which axis is backwards? I will test it when I get back to my machine.

Does the laser work now in T2Laser?

lenjsr

  • Newbie
  • *
  • Posts: 35
    • View Profile
Re: Power not increasing on laser when g code sent
« Reply #44 on: December 13, 2016, 01:25:38 PM »
it works with t2 laser but backwards. Ben box no . reverse x axsis solves backward problem now, will not cut paper with t2 laser but will with ben box with original software. the fan stays on with new hex code from you