Author Topic: Anyone have any experience with this 'improved' board?  (Read 5742 times)

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6000
    • View Profile
    • T2Laser
Re: Anyone have any experience with this 'improved' board?
« Reply #15 on: February 26, 2017, 05:53:04 AM »
So you have a TTL laser and connected to the laser output, correct?

It sounds like the laser may be faulty.

roby320d@

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: Anyone have any experience with this 'improved' board?
« Reply #16 on: February 26, 2017, 06:04:52 AM »
Yes,i have a TTL module connected to his Mana SE.
I'm one of the Bangood buyer that have received the new board with the A3 2500mw engraver.
« Last Edit: February 26, 2017, 06:26:25 AM by roby320d@ »

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6000
    • View Profile
    • T2Laser
Re: Anyone have any experience with this 'improved' board?
« Reply #17 on: February 26, 2017, 06:36:20 AM »
I have a Mana SE board also, the S-pin is just connected to the PWM output on the Nano so if your firmware is loading correctly that would not be enabled.

So for the laser to be ON it must have a failed driver.

You could test by removing the S pin from the cable, and connecting the laser side to ground. Then it has 12V/Gnd/Gnd and should be off.

roby320d@

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: Anyone have any experience with this 'improved' board?
« Reply #18 on: February 26, 2017, 06:55:39 AM »
Remove the pwm pin on the laser side and connect it to ground?
I notiche that the laser cable have one connector different from the other side,one have red-black-white and the other White-black-red watching them on the same side.

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6000
    • View Profile
    • T2Laser
Re: Anyone have any experience with this 'improved' board?
« Reply #19 on: February 26, 2017, 06:59:36 AM »
That doesn't sound correct but I didn't purchase the kit, just the Mana SE and Mana CNC boards to test with T2Laser.

So I wired my TTL laser myself, it should have 12V, GND and PWM. I was suggesting to remove the PWM pin from the Mana SE board so you can ground it, that way you know for sure it's a laser issue but you may have found the problem.

roby320d@

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: Anyone have any experience with this 'improved' board?
« Reply #20 on: February 26, 2017, 07:20:11 AM »
No way.....
I try to make the mod that you suggest,but laser is on.
I have tried to change the external pin of the connector,but the only thing that occur is that the laser is permanently off,and the button on the laser didn't take effect
I have check the pin on the board and the pin on the laser module,and i have noticed that in effect they are in inverted sequence respect the Mana SE,this mean that the cable is correct.
Strange though that the thing is common to many others.

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6000
    • View Profile
    • T2Laser
Re: Anyone have any experience with this 'improved' board?
« Reply #21 on: February 26, 2017, 07:26:50 AM »
Probably a bad laser then, maybe EleksMaker Z can confirm but if it's always on even with the S (PWM) pin disconnected from the board and laser side grounded then it has to be faulty.

roby320d@

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: Anyone have any experience with this 'improved' board?
« Reply #22 on: February 26, 2017, 07:31:13 AM »
This tipe of post is very diffused........

« Last Edit: February 26, 2017, 07:39:23 AM by roby320d@ »

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6000
    • View Profile
    • T2Laser
Re: Anyone have any experience with this 'improved' board?
« Reply #23 on: February 26, 2017, 07:50:05 AM »
Without knowing the context of those posts it's difficult to say, there are other reasons for the laser to be permanently on but usually a mismatch between firmware and board. In your case it seems that is not the cause but some hardware fault.

roby320d@

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: Anyone have any experience with this 'improved' board?
« Reply #24 on: February 26, 2017, 08:10:11 AM »
The majority of users having this problem think it's the fault of the wrong firmware.
The Bangood customer service think the same,and i'm waiting their link for updated software,because the link that they send me Yesterday needed a key to decript.
« Last Edit: February 26, 2017, 08:15:15 AM by roby320d@ »

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6000
    • View Profile
    • T2Laser
Re: Anyone have any experience with this 'improved' board?
« Reply #25 on: February 26, 2017, 08:22:03 AM »
As I said, I have the same board and using my Grbl 1.1e firmware it works correctly.

roby320d@

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: Anyone have any experience with this 'improved' board?
« Reply #26 on: February 26, 2017, 08:36:13 AM »
And which laser module do you use?
Mine is a TTL 2.5w

nottingham82

  • Hero Member
  • *****
  • Posts: 1680
    • View Profile
Re: Anyone have any experience with this 'improved' board?
« Reply #27 on: February 26, 2017, 08:45:12 AM »
the laser module doesnt care about firmware.  All the laser knows is power, signal, and ground.  It does not get the code.  The most having a different laser will mean is that yours is possibly wired wrong. 
Laser: 2500mw A5 eleks maker
OS: Windows 10 all in one pc
Software: T2
http://www.gearbest.com/3d-printers-3d-printer-kits/pp_290386.html Paid $160 in 2016

roby320d@

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: Anyone have any experience with this 'improved' board?
« Reply #28 on: February 26, 2017, 08:53:54 AM »
I have connected the laser with the cable supplied with the kit,and i check the pin on the board and on the module,and they match perfectly.
12v on the board with VCC on the module,GND with GND and PWM with PWM.
And i just connect the pwm pin on laser side to ground as you recommended,but laser Always on.
At this point then you tell me that the laser module is faulty?
 :'( :'( :'( :'(

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6000
    • View Profile
    • T2Laser
Re: Anyone have any experience with this 'improved' board?
« Reply #29 on: February 26, 2017, 09:07:47 AM »
I have the 2W TTL module. With only 12v connected (no PWM source) the laser is off.