Author Topic: Mana SE laser issue...  (Read 2233 times)

a_kent

  • Newbie
  • *
  • Posts: 14
    • View Profile
Mana SE laser issue...
« on: March 01, 2017, 12:57:35 PM »
Issue: The Mana SE leaves the Laser PWM signal floating.

This is not an issue when the Nano is actively driving it, but it is when the USB cable is disconnected and when the Nano is booting up and any other time the signal is left floating, such as when T2L goes into Laser control mode.

I read in the other thread where Zax is using this board with a 2watt laser module that does not turn on when the PWM signal is open. Apparently, this Laser module includes a PWM pull down.

I have two laser modules, one 2.5watt and one 3.5watt that both turn on.

The fix for the 2.5 and 3.5 watt laser (and likely others) is to solder a 1k ohm resister between the laser PWM signal and ground. The PWM is the 'S' signal on the connector. Ground is the center pin.

Note that this fix is also needed if you are using the red motor port. This same signal also drives the low side of the motor port through a Mosfet.

Best,
Kent

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6000
    • View Profile
    • T2Laser
Re: Mana SE laser issue...
« Reply #1 on: March 02, 2017, 04:58:03 AM »
See this thread: http://benboxlaser.us/index.php/topic,1705.msg20815.html#msg20815

The resistor is between the S (signal/PWM pin) and the - (ground pin) on the laser connector.

ThothLoki

  • Hero Member
  • *****
  • Posts: 2092
  • Tinkerer
    • View Profile
Re: Mana SE laser issue...
« Reply #2 on: June 10, 2017, 10:55:32 PM »
See this thread: http://benboxlaser.us/index.php/topic,1705.msg20815.html#msg20815

The resistor is between the S (signal/PWM pin) and the - (ground pin) on the laser connector.

Can you post a pic or the resistor? My new laser comes on now with the mana SE when I go to the control screen.
Laser: A5 2000mw with L7 Board / A3 2500mw PWM with Mana SE -- All using T2Laser
3D Printer: Monoprice Maker Select v2.1
Image Resizer Applications (All OS): http://benboxlaser.us/index.php/topic,1434.msg17297.html#msg17297

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6000
    • View Profile
    • T2Laser
Re: Mana SE laser issue...
« Reply #3 on: June 11, 2017, 04:41:45 AM »
Sorry I don't have a picture as I haven't needed the mod, both my TTL lasers work correctly. They're the kind with external drivers not the EleksMaker style with everything on the module. I do have a new "blue" EleksMaker laser on the way and they claim it has a built in pull down so doesn't come on at full power.

I've seen a few different options for where to put the resistor; the plug, input to laser or on the back of the board near the connector. You are just connecting the TTL signal (S pin) to ground (- pin) so it is pulled low rather than left floating.

nottingham82

  • Hero Member
  • *****
  • Posts: 1680
    • View Profile
Re: Mana SE laser issue...
« Reply #4 on: June 11, 2017, 06:02:43 AM »
as a work around, could you just have the power turned off when you connect to the nano.  then after the handshake with the nano turn the power on?
Laser: 2500mw A5 eleks maker
OS: Windows 10 all in one pc
Software: T2
http://www.gearbest.com/3d-printers-3d-printer-kits/pp_290386.html Paid $160 in 2016

ThothLoki

  • Hero Member
  • *****
  • Posts: 2092
  • Tinkerer
    • View Profile
Re: Mana SE laser issue...
« Reply #5 on: June 11, 2017, 07:13:05 AM »
@zax, I had this issue for a while with my old machine, but it went away somehow
I will just keep the board off until it is done connecting.
Laser: A5 2000mw with L7 Board / A3 2500mw PWM with Mana SE -- All using T2Laser
3D Printer: Monoprice Maker Select v2.1
Image Resizer Applications (All OS): http://benboxlaser.us/index.php/topic,1434.msg17297.html#msg17297