Author Topic: ElekMaker laser always on when power button on device pressed  (Read 529 times)

ivanlc

  • Newbie
  • *
  • Posts: 21
    • View Profile
[ADDENDUM: was looking in the wrong forum and just found the Troubleshooting forum which has some posts from people with the same issue, and which I'm now investigating...]

Hi. I tried searches for this on the forum, but came up empty.

I'm a complete newbie to laser engraving, and had gotten the Benbox software to eventually work, although as widely acknowledged, it's somewhat lacking.

I bought a T2 licence and updated the firmware to GRBL 1.1e, as I read in a post that to use T2, the Benbox firmware needs to replaced. (I did this as the cursor buttons to move the laser head were reversed and this couldn't be changed without the GRBL firmware, as said in the aforementioned post.)

The laser now appears to be controlled correctly, but when I hit the power/laser on button on the ElekMaker, the laser is permanently on.

Why is this and what do I need to change to stop it, as it is burning the base I've got the engraver sat on... :-\

Apologies if this has been answered elsewhere, but I couldn't find anything when I searched either on the forum. And the T2 Laser guides mention nothing about this.

Please do request additional info if you've an inkling as to what might be going on (but bear in mind I haven't got the technical vocabulary down yet; MOSFET, Nano, etc and how they relate to what I'm looking at, don't mean anything to me yet, so if you could explain what I'm to look for a little, we'll make faster progress!! ;))

Regards,

ivan
« Last Edit: March 25, 2017, 02:17:39 AM by ivanlc »

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4027
    • View Profile
    • T2Laser
Re: ElekMaker laser always on when power button on device pressed
« Reply #1 on: March 25, 2017, 03:57:57 AM »
What board do you have? Eleks Mana or L7

If it's the L7 did you move the jumper to the 0.9 position (see my conversion document)


Does the laser have 3 wires, and is connected to the laser socket?

When you loaded the firmware, you selected the default one and not one from the custom menu - correct?

Madmark

  • Full Member
  • ***
  • Posts: 101
  • Do NOT look into beam with remaining good eye!
    • View Profile
Re: ElekMaker laser always on when power button on device pressed
« Reply #2 on: March 25, 2017, 10:39:53 AM »
Press the other button to turn off the weak laser at startup.

M
GearBest A5 - 1600mW
LX-5 controller w/single MOSFET & GRBL jumper
Benbox 3.7.99
AutoCAD 2k .DXF
Ancient 2GB Dell Optiplex w/USB scanner

roby320d@

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: ElekMaker laser always on when power button on device pressed
« Reply #3 on: April 09, 2017, 02:11:37 AM »
This is the same problem that i have.
Finally i discovered the cause of it.
Is the pwm board on the top of laser module.
First i try a new ManaSE to exlude it,and the problem was the same of the old ManaSE,then i try to connect the laser + and - ti + and - of the 12v connector on ManaSE,and the problem disappear,obviously all without PWM function enabled.
In the meanwile that customer service send me a spare parts of the laser module,an 2,5w TTL,i have bought a 2,5w non TTL that works perfecly on the red connector of ManaSE.

olbar70

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: ElekMaker laser always on when power button on device pressed
« Reply #4 on: April 23, 2017, 02:56:51 PM »
Have the same issue. Also , just put this machine together .
The board is Mana SE

RVTMSW

  • Newbie
  • *
  • Posts: 17
    • View Profile
Re: ElekMaker laser always on when power button on device pressed
« Reply #5 on: May 13, 2017, 10:40:32 AM »
This is the same problem that i have.
Finally i discovered the cause of it.
Is the pwm board on the top of laser module.
First i try a new ManaSE to exlude it,and the problem was the same of the old ManaSE,then i try to connect the laser + and - ti + and - of the 12v connector on ManaSE,and the problem disappear,obviously all without PWM function enabled.
In the meanwile that customer service send me a spare parts of the laser module,an 2,5w TTL,i have bought a 2,5w non TTL that works perfecly on the red connector of ManaSE.

My board is a clone of Eleksmaker board + TTL board. There was a time that I was frustrated when my laser is always shoot at a max power. It used to be fine with benbox and controlled laser power before I did an experiment for upgrading the firmware to 0.9i GRBL.

And my MISTAKE was to skip the TTL board by directly connect the laser to the controller board.
The laser was shooting with maximum power until it's POP! DONE!

My suggestion is that when you feel that your TTL board is faulty, buy a new one.
It is a way cheaper rather than loosing the diode laser.
My laser is 5500mW.  :'(
« Last Edit: May 18, 2017, 07:45:28 AM by RVTMSW »
No skills, but willing to learn Computer Engineering.
5.5W Chinese Laser Cutter: EleksMaker X1 + TTL
TEVO Tarantula i3 Prusa
Windows 10
Benbox V3.7.99
Rhinoceros 5 (64bit)
Autodesk Fusion 360