Author Topic: New Member, another laser issue on EleksMaker Mana SE  (Read 2156 times)

MicB

  • Newbie
  • *
  • Posts: 10
    • View Profile
New Member, another laser issue on EleksMaker Mana SE
« on: October 22, 2017, 03:42:51 PM »
Hi,

I've just joined the forum. I've had my laser cutter for a few weeks, and struggling to get the thing running.

Picked it up from ebay, was described as a laseraxe A3.

I have access to cam software and can export as DFX's so my plan was to import this into the laseraxe software, but the software kept crashing and hanging every time I tired. Then found out about t2, picked up a new board as I was unable to get the laseraxe one to work with T2, and had read about some of the older laseraxes not playing well after being flashed (my original board is now bricked)

I did have the original board and laser up and running, and have burnt my desk with it, so it was working.

Picked up this as a new board (https://www.amazon.co.uk/gp/product/B073TY9N1V/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1) I'm not sure why I went for the 3 axis one.

With a lot of messing about this evening I'm finally managed to get T2 to connect to the machine, but the laser will no turn on. It's a non TTL laser, so it's plugged into the "motor" plug.

Am I missing something, is there anything I have to change in the T2 software to tell it this?

Is there anything else I can try?

Thanks
Mic



nottingham82

  • Hero Member
  • *****
  • Posts: 1699
    • View Profile
Re: New Member, another laser issue on EleksMaker Mana SE
« Reply #1 on: October 22, 2017, 04:11:13 PM »
did you flash the board with firmware 1.1e?

Are you sure the motor plug is wired the same as your laser?  + to + and - to -?
Laser: 2500mw A5 eleks maker
OS: Windows 10 all in one pc
Software: T2
http://www.gearbest.com/3d-printers-3d-printer-kits/pp_290386.html Paid $160 in 2016

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6134
    • View Profile
    • T2Laser
Re: New Member, another laser issue on EleksMaker Mana SE
« Reply #2 on: October 22, 2017, 04:29:43 PM »
Try what nottingham82 suggested, or post a picture of your laser. There's nothing special in T2Laser that needs to be set.

MicB

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: New Member, another laser issue on EleksMaker Mana SE
« Reply #3 on: October 22, 2017, 04:36:19 PM »
did you flash the board with firmware 1.1e?

Yes.

Are you sure the motor plug is wired the same as your laser?  + to + and - to -?
Doesn't look like it, I'll try and swap them over.

Will report back. Thanks

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6134
    • View Profile
    • T2Laser
Re: New Member, another laser issue on EleksMaker Mana SE
« Reply #4 on: October 22, 2017, 04:45:38 PM »
Does the laser connection go directly to the module or is there some intermediate box?

The motor output is a 12VDC signal so the laser must be compatible.

MicB

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: New Member, another laser issue on EleksMaker Mana SE
« Reply #5 on: October 22, 2017, 05:17:01 PM »
Swapped them over, still got nothing.

The laser goes straight into the module, there is nothing in-between.

The laser unit has got a fan on it, and that doesn't move.

I just tried plugging the dc input from the transformer straight into the laser, and the laser fired up. So the laser works.

Thanks.

**just plugged a pc fan into where the laser is plugged in and it does nothing. I've not got a multi meter so I'm unable to test,  think this is on hold until tomorrow.
« Last Edit: October 22, 2017, 05:36:17 PM by MicB »

nottingham82

  • Hero Member
  • *****
  • Posts: 1699
    • View Profile
Re: New Member, another laser issue on EleksMaker Mana SE
« Reply #6 on: October 22, 2017, 11:26:21 PM »
only thing I can think of is your power supply may have died.  Do you have any other 12 volt power supplies with a barrel jack you could try?

Also... this may be a dumb question but did you try pressing the little white button that says power on the new board?
Laser: 2500mw A5 eleks maker
OS: Windows 10 all in one pc
Software: T2
http://www.gearbest.com/3d-printers-3d-printer-kits/pp_290386.html Paid $160 in 2016

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6134
    • View Profile
    • T2Laser
Re: New Member, another laser issue on EleksMaker Mana SE
« Reply #7 on: October 23, 2017, 04:43:06 AM »
Check that you get 12VDC from the +/- pins on the laser port, if not, there's something wrong.

It could be as simple as the white power button not latching, or one of the input capacitors is bad or the power supply isn't working.

MicB

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: New Member, another laser issue on EleksMaker Mana SE
« Reply #8 on: October 23, 2017, 05:27:45 AM »
Also... this may be a dumb question but did you try pressing the little white button that says power on the new board?

Not a dumb question, it is something that could of been over looked.

I'll see if I can source a new power supply.

The fact that I can move the gantry on the x and y, and the power supply will power the laser when plugged in direct suggests that it's not the power supply, but I will try. The one I've got is a 12v 5amps, do I need more amps?

I'll also have a play with the old laseraxe board and see if I can un-brick it.


MicB

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: New Member, another laser issue on EleksMaker Mana SE
« Reply #9 on: October 23, 2017, 05:28:40 AM »
Is it also possible to convert a 2 pin laser to a 3 pin? Or am I barking up the wrong tree?

ggallant571

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2344
    • View Profile
Re: New Member, another laser issue on EleksMaker Mana SE
« Reply #10 on: October 23, 2017, 07:50:51 AM »
I do not have you hardware but most of these laser modules follow similar electrical schemes. There are 2 major arrangements:

    1. 12V PWM - older boards
    2. 5V TTL  - newer boards

With the older 12VPWM boards there are 2 wire between the controller and the laser module. The controller contains a power MOSFET which switches the 12V on/off.

With the new systems the power switching has been moved to the laser module (or separerate board) and either 3 or 4 wires are used.

   1. 12V with wires capable of 3A
   2. GND good for 3A
   3. TTL signal
   4. TTL signal GND (only on 4 wire setup)

IMPORTANT - If you have a 4 wire laser module and a 3 wire controller yo need to connect the GNDs at the module. My 1.6W module has 2 2-pin headers and I join the GNDs at the wires.

SARCASM - Just one more service we offer here.

MicB

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: New Member, another laser issue on EleksMaker Mana SE
« Reply #11 on: October 23, 2017, 12:40:22 PM »
Check that you get 12VDC from the +/- pins on the laser port, if not, there's something wrong.

I get nothing from the 2 pin "Motor" + and - but do get 12v from the 3 pin laser.




Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6134
    • View Profile
    • T2Laser
Re: New Member, another laser issue on EleksMaker Mana SE
« Reply #12 on: October 23, 2017, 12:44:56 PM »
The motor port is only active when the laser is supposed to be on, it's controlled by the MOSFET.

The laser +/- is always on as the laser is switched with the TTL (S) pin.

MicB

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: New Member, another laser issue on EleksMaker Mana SE
« Reply #13 on: October 23, 2017, 12:53:00 PM »
I ran T2 and switched the laser on, and still got nothing.

But in a weird series of events, I attempted to connect to the original laseraxe box, and for some reason T2 connected and got the Grbl1.1f ready back. This threw me, so restarted the board, and T2 just in case it was a weird error and it wasn't actually connected.

I've now plugged it back in, and it works.

I have no idea what or how, or why.

But it works on the original box, somehow flashed with Grbl1.1f (it told me it hadn't updated and then wouldn't connect)


Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6134
    • View Profile
    • T2Laser
Re: New Member, another laser issue on EleksMaker Mana SE
« Reply #14 on: October 23, 2017, 12:58:36 PM »
That is weird, so it's all working, motors move correctly and the laser on/off?