Author Topic: I need help setting up this machine  (Read 4031 times)

donwatson

  • Full Member
  • ***
  • Posts: 214
    • View Profile
I need help setting up this machine
« on: March 08, 2018, 10:05:55 AM »
Hi All,
I bought a Laser Engraver from a friend this morning and need some help identifying it and setting it up.
I have attached (hopefully) a couple of pics of the setup.
The only thing I can say for certain is the power supply adaptor supplies 12V 3A.
I have a blue USB connector coming from this machine which I presume is for the Computer.
I have a load of questions to ask but don't know where to ask them, Would it be better in a general thread ? as this is the T2 part of the forum and I am only here because my friend had bought the T2 software


ggallant571

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3225
    • View Profile
Re: I need help setting up this machine
« Reply #1 on: March 08, 2018, 11:23:01 AM »
You have a fairly typical setup. The controller board seems to be lacking vendor details. Recall seeing the product on multiple user posts so hopefully someone will reply with specifics. I would unplug the laser and get the firmware with primitive x/y motion working first. Ralph & Zax (the laser twins) are both experts with their respective products and respond well to well formed questions. I use Linux and would test with simpler tools such a raw gcode on a terminal emulator or GrblController.
SARCASM - Just one more service we offer here.

rpt007

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: I need help setting up this machine
« Reply #2 on: March 08, 2018, 12:29:23 PM »
Just to add to what @ggallant571 said:
1. think big, but start small

2. Get familiar with your system and the T2 software and let the x and y axis move into the right directions first (without the laser connected to the laser pins!)
3. Check, how fast you can go and if your system really moves back and forth flawlessly - belt tensions, wheels with just a mimimum of play to avoid backlash etc.
4. Simulate a first project and see how the x-carriage moves around and at the end comes back to the starting point

When I did my first steps with my laser system, after 1.-4. I took a blue LED (and a 1k resistor in series) and connected the LED to the laser pins on the controller board.
Then I could play with the software, move the axis, switch on and off the blue LED, increasing or decreasing the LED's brightness (later: laser power) etc.

Thus I avoided to burn unintentionally holes in my desktop, avoided being exposed to unhealthy smoke and eventually took over control before I attached the real laser to my system.
After that I knew that my machine was set up right and I only had to deal now with finding the  focus, speed and laser intensity to get the first results, which still is sometimes an issue of its own (provided that the power supply is strong enough and not adding one more complexity level).

Maybe this gets you started a bit. If you have questions, don't hesitate.
Do you have already thought about a solution yourself or is a part of the problem sitting in front of the screen?

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7283
    • View Profile
    • T2Laser
Re: I need help setting up this machine
« Reply #3 on: March 08, 2018, 03:47:42 PM »
If you haven't done so, step 1 is to install the device driver for your laser. It can be found in the Help menu of T2Laser.

Then you should be able to connect to the laser and start testing it.

donwatson

  • Full Member
  • ***
  • Posts: 214
    • View Profile
Re: I need help setting up this machine
« Reply #4 on: March 09, 2018, 03:57:39 AM »
This is the third attempt at writing this thread today  :-[
Firstly Thanks for your (very quick) replies to my questions. I have some experience with this machine as I was helping her to get it up and running  when she gave up working with it (health reasons). She had purchased T2 as after the trial we did it was quite hard to try and learn things and get it running before the 30 minutes were up.
The first problem we found, I have put on this forum in the thread " burn appears to move " and I have checked the belts on the "y" axis and they appeared a bit tight so were eased off a little, and to answer @Alan, the power supply is 12V 3A.
I burnt the sample 50mm rings last night and have attached a picture of the result.
The centre one was first and there seems to be a bit missing on the right hand side but the other 2 turned out ok.
I have so many questions I don't know where to start.
The first thing I see is the carriage that carries the laser rattles about on the frame. Can I elongate the upper set of holes to give some adjustment to tighten this up ??
I will have a look through Zax's videos and see what I can glean from there, but, along with the laser engraver comes a pile of paperwork that seems to have been copied from this forum but it is a bit cryptic, for example the page at the top of thepile says
1 Upload Firmware
2 Reset Default Parameters ???
I will be back

Don W




Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7283
    • View Profile
    • T2Laser
Re: I need help setting up this machine
« Reply #5 on: March 09, 2018, 04:39:18 AM »
I don't know what happened to the first circle but the others look good, I don't see any signs of backlash or missed steps.

The carriage should not have any wobble so yes you may need to adjust the wheels, if needed you can elongate the holes although there is usually another play in the bolts that this isn't needed.

You should have Grbl 1.1e firmware loaded, everything appears to be working so I wouldn't change it right now.

Default parameters (refers to the Grbl settings), again, if it ain't broke, don't fix it!

I read the last statement with my internal Terminator voice... not sure if that was intended, but we will be here...  ;)

ggallant571

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3225
    • View Profile
Re: I need help setting up this machine
« Reply #6 on: March 09, 2018, 05:12:43 AM »
You can save some money getting "Neon" 3x5 inch index cards.  $2.50US for 100 at Walmart. They react to the laser nicely at relatively low power. Good for verifying x/y motions plus you can use high speeds.
SARCASM - Just one more service we offer here.

donwatson

  • Full Member
  • ***
  • Posts: 214
    • View Profile
Re: I need help setting up this machine
« Reply #7 on: March 10, 2018, 01:53:00 PM »
Hi,
I have set up a Virtual machine in my Linux computer and tried to use the key to get the T2 program registered. It comes up with Key not valid. I only set this VM up because when I copy the key to my windows computer it says the same thing key not valid.
I don't know what is happening but I don't like using Windows, that is why I set up a VM in Linux. Is there anything I can do ??

EDIT I will try various things today and see what transpires.
I will be back
« Last Edit: March 11, 2018, 03:20:02 AM by donwatson »

donwatson

  • Full Member
  • ***
  • Posts: 214
    • View Profile
Re: I need help setting up this machine
« Reply #8 on: March 11, 2018, 08:54:08 AM »
I am back :D
I have a new computer setup so I will try it out for a while before I make any more decisions.

Don W
Edit I have had a little time to play this morning and burnt 2 sets of  circles on a piece of 3mm ply wood.
I think they look ok and will do a bit more with a raster image to see how that will do.
I had to use a feed rate of 500 at full power (255) to get this burn. I tried at 1000 but the line was very faint. I don't know if the beam needs focused.
Don W


« Last Edit: March 13, 2018, 06:19:22 AM by donwatson »

donwatson

  • Full Member
  • ***
  • Posts: 214
    • View Profile
Re: I need help setting up this machine
« Reply #9 on: March 14, 2018, 04:46:31 AM »
Hi All,
I have a fully operational T2 up and running on my computer  :D :D
Now to get some serious work done ??
Thanks for all your help and advice, I am just so pleased to get up and running.

take care
Don W

donwatson

  • Full Member
  • ***
  • Posts: 214
    • View Profile
Re: I need help setting up this machine
« Reply #10 on: March 19, 2018, 11:33:14 AM »
I need some more help please.
The vector imaging seems to be ok. I have attached the dragon I copied recently. It was nicely burnt, the size is what I wanted and it was in the correct position on the sheet.
However the raster imaging is proving a bit of a problem. I have stripped the machine down and checked all the spacers for length, wheels checked to see if the bearings were central etc. etc. I re-assembled the machine and set the belt tension as Ralph shows in his video. I have ordered a 5A power adaptor that will be delivered on Wednesday but I could not wait and so had another go at a raster burn.
It did not take long before the flaws started to show. I noticed the stepper motor on the X axis stopped occasionally and the programme seemed to pause around the 4% mark until I clicked on the left mouse button. These are the problems at the moment, can anyone help ?? please.

Don W
I have attached a pic of the dragon that was ok.
I have also attached a copy of the logo I wanted to burn and the burn I did with it
« Last Edit: March 19, 2018, 11:36:21 AM by donwatson »

donwatson

  • Full Member
  • ***
  • Posts: 214
    • View Profile
Re: I need help setting up this machine
« Reply #11 on: March 21, 2018, 06:55:18 AM »
I found a thread where Michal was having problems setting up his laser engraver and noted that ggallant571 had suggested checking the spacers in the X axis carriage.
I stripped the carriage and fitted the 12mm spacers on the motor side and re-assembled.
I followed the video by "Laser Graffiti" and have burnt some 10mm circles as he describes. They were very small and I thought there was a problem on the left and right hand sides of them.
I then burnt a 50mm diameter circle that showed there was indeed a problem. I have attached the picture of this burn.
I will try other materials until I can get a consistent burn but in the meantime can anyone suggest how I can correct this problem. ??

Don W
EDIT I have  burned another 50mm circle, this time on 3/8" MDF and it has burned no problem
« Last Edit: March 21, 2018, 07:56:14 AM by donwatson »

donwatson

  • Full Member
  • ***
  • Posts: 214
    • View Profile
Re: I need help setting up this machine
« Reply #12 on: March 22, 2018, 03:23:27 PM »
I made a burn of Tweety tonight and he seemed to come out ok. I burned on 3/8" thick MDF
I fitted a new 5A power adaptor yesterday, it may have made a difference.

ggallant571

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3225
    • View Profile
Re: I need help setting up this machine
« Reply #13 on: March 22, 2018, 04:31:50 PM »
Welcome to the realm of uncertainty. What I have observed is may of the components that go into a low cost diode laser machine are marginal. It worked once in China lab so they cut the working units in half and wait for users to complain.
SARCASM - Just one more service we offer here.

ThothLoki

  • Hero Member
  • *****
  • Posts: 2188
  • Tinkerer
    • View Profile
Re: I need help setting up this machine
« Reply #14 on: March 22, 2018, 09:32:38 PM »
I made a burn of Tweety tonight and he seemed to come out ok. I burned on 3/8" thick MDF
I fitted a new 5A power adaptor yesterday, it may have made a difference.

Tweety looks good. You may want to reduce your resolution spacing though. What are you burning at? 0.2?
Laser: A3 2500mw with L7 Board / A3 2500mw PWM with Mana SE -- All using T2Laser
3D Printer: Monoprice Maker Select v2.1
Image Resizer Applications (All OS): http://benboxlaser.us/index.php/topic,1434.msg17297.html#msg17297