Author Topic: Grayscale: Black border around white area  (Read 854 times)

Arkash

  • Newbie
  • *
  • Posts: 3
    • View Profile
Grayscale: Black border around white area
« on: April 24, 2018, 11:54:35 AM »
Hello,

I searched on the forum but I might not use the right words. Pardon me if I missed a post.

Today I've tried my first grayscale engravings.

I used this post to set T2L: http://benboxlaser.us/index.php/topic,1461.msg17702.html
I finally got something ok so I wanted to test with a picture (attachment 1)

Settings:
- Photo mode ON
- Velocity mode ON
- Power : 23
- Feed rates : 290 / 1500
- Resolution : 0.15

The gcode viewer result : attachment 2.
Everything seemed ok so I engraved : see attachment 3.

You can see a big black border around every white area (sorry for the diagonal scratch, I did it, not the laser...)

I thought it was because of acceleration so I turned it off (I cannot upload firmware 1.1 to use dynamic mode)
Result (attachment 4) is slightly better but the borders are still there.

Do you have any idea why it happens ?

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7281
    • View Profile
    • T2Laser
Re: Grayscale: Black border around white area
« Reply #1 on: April 24, 2018, 01:29:48 PM »
Usually that is from the laser turning on, but using velocity mode you should not see that so I am not sure.

Arkash

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Grayscale: Black border around white area
« Reply #2 on: April 25, 2018, 12:50:03 AM »
The laser does turn off/on for those white areas.
Maybe power on start is not properly set ?

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7281
    • View Profile
    • T2Laser
Re: Grayscale: Black border around white area
« Reply #3 on: April 25, 2018, 04:44:55 AM »
It's a fault with the laser driver, it isn't limiting in rush current at startup which will eventually cause early failure of the diode.

In T2Laser change the min laser value to 5 which will prevent the switching off for larger white areas, you may need to slightly increase the rapid feed rate value to prevent any burning of those areas.

Also, don't enable photo mode manually. You should have received a warning about that when turning it on, that setting is best controlled automatically by the algorithm.
« Last Edit: April 25, 2018, 04:45:51 AM by Zax »

Arkash

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Grayscale: Black border around white area
« Reply #4 on: April 25, 2018, 05:29:10 AM »
I'll try that and turn off photo mode.

Thanks Zax !