Author Topic: Laserweb error: 20 - Unsupported or invalid g-code command found in block  (Read 980 times)

jc2046

  • Newbie
  • *
  • Posts: 28
    • View Profile
Hi,

Im using laserweb with inkscape with my elekslaser. It runs nice and smooth, but sometimes I found this:

error: 20 - Unsupported or invalid g-code command found in block

Somehow it seems like the conversation between inkscape and laserweb get disorted. I have search but it seems thereīs no references on inet on how to solve this.

If someone knows whatīs happening and how to fix it would be super useful.

Thanks

ggallant571

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2407
    • View Profile
Pleas post a gcode file that faults. The Nano has a very small buffer for incoming commands. Most host software tries to keep slightly ahead
 of the physical motion by monitoring the "ok" or "error" response codes. If your files is very verbose (lots of extra decimal digits) in the X,Y.Z moves you might end up overwriting the buffer.
SARCASM - Just one more service we offer here.

jc2046

  • Newbie
  • *
  • Posts: 28
    • View Profile
Ok, I think I know what is. It happens once the work is done. In the configuration of my laserweb I have GCODE END : M18;

Im almost sure is that the machine doesnīt understand this command, because it only launch the error once the work is done. I canīt  proof it now cause is working now, but I guess changing this line for

M5;
G28;

should do the job.

Iīll try later and report for the record. Thanks for being supportive, Gagallant  ;)
« Last Edit: July 09, 2018, 12:19:20 PM by jc2046 »

jc2046

  • Newbie
  • *
  • Posts: 28
    • View Profile
Confirmed: The error was solved