Author Topic: Elekslaser A3 Pro - Homing Cycle issues with grbl1.1e  (Read 85 times)

KEtheredge87

  • Newbie
  • *
  • Posts: 2
    • View Profile
Elekslaser A3 Pro - Homing Cycle issues with grbl1.1e
« on: July 08, 2018, 06:37:21 PM »
Hi Everyone,

I've tried to do some serious googling to understand and troubleshoot my issues thus far, without much success. Hoping now to poll the wisdom of the group to solve my issue!

I am setting up an Eleksmaker A3 Pro to use Normally Open momentary switches to establish homing function and hard limits. At this point, I can manually jog the laser in any direction correctly (left goes left... up goes up... etc), but as soon as I hit the "Home" button or send a "$H" command, the lightburn software shows the laser as "Busy", but no movement of the laser carriage. I get similar behavior from LaserWeb software as well, but it at least gives me a warning saying "Gcode outside of machine bounds, can lead to running work halt." I'm still trying to diagnose that one...

A printout of my current grbl settings is attached below, but here's the rundown of the system and software settings at the moment:

Board: EleksMaker Mana SE with EleksMaker arduino nano clone
Stepper Motor Drivers: Trinamic SilentStepStick TMC2130 (replaced stock driver chips)
Firmware: grbl 1.1e (flashed via the Arduino IDE - Did have to tell Arduino that the board was an Arduino Duemilanove / Diecimila to get the firmware to flash)
Computer: 2012 Macbook Air running macOS High Sierra Version 10.13.3 (17D47)
Laser Software: Using Lightburn or LaserWeb (doesn't seem to matter which... issue still persists)
Origin Setting (or at least intention): Set such that top right is (0,0), and homing should go to top right as (0,0)

Things I tried so far:
1) Updated config.h file to enable proper homing as shown below --> reflashed grbl to board after changes
//#define HOMING_CYCLE_0 (1<<Z_AXIS)                // REQUIRED: First move Z to clear workspace.
#define HOMING_CYCLE_0 ((1<<X_AXIS)|(1<<Y_AXIS))  // OPTIONAL: Then move X,Y at the same time.
#define LIMITS_TWO_SWITCHES_ON_AXES


2) Added noise suppression circuit to the setup using 1Kohm resistors and 220nF capacitors based on grbl instructions for X and Y axis only. (https://github.com/gnea/grbl/wiki/Wiring-Limit-Switches). I only had 1Kohm and 0.22uF (220nF) parts on-hand, used them to try without really understanding if the values of 4.7K and 100nF are critical to success in this application.

At this point I am officially out of my depth, so I'm hoping someone can help guide me to the light! How do I get the homing behavior to start appropriately? Can anyone have a look at my output below and hopefully tell me I'm doing something horribly dumb? Thanks in advance!

Current Output from Lightburn Console upon connecting to EleksLaser A3 Pro via USB
Port opened, waiting for response.
�$���V�
Grbl 1.1e ['$' for help]
[MSG:'$H'|'$X' to unlock]
[MSG:Caution: Unlocked]
ok
$$
$0=10
$1=25
$2=0
$3=2
$4=0
$5=0
$6=0
$10=3
$11=0.010
$12=0.002
$13=0
$20=0
$21=1
$22=1
$23=1
$24=1000.000
$25=2000.000
$26=250
$27=2.000
$30=1000
$31=0
$32=0
$100=80.000
$101=80.000
$102=80.000
$110=5000.000
$111=5000.000
$112=5000.000
$120=100.000
$121=100.000
$122=100.000
$130=380.000
$131=300.000
$132=5000.000
ok

KEtheredge87

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Elekslaser A3 Pro - Homing Cycle issues with grbl1.1e
« Reply #1 on: July 08, 2018, 07:33:19 PM »
I think I fixed my issue. Had too many copies of grbl floating around, and I believe the Arduino IDE was referencing the wrong control.h file! I just got the home function to work for LightBurn, even though it homed to the bottom left rather than the top right as expected. Progress though!