Author Topic: Stepper motor problem  (Read 306 times)

ggallant571

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2469
    • View Profile
Stepper motor problem
« on: September 04, 2018, 04:46:42 PM »
I am having a strange stepper motor problem. The etcher has a single motor on the X axis and 2 motors on the Y. X is working fine, Either of the Y's by themselves is OK. Both Y's and they seem to be fighting each other. Lots of jitter and noise. Almost as if one motor was being driven as a generator. Swapped cables and driver boards. This fixture had been working very smoothly. I think all three motors are identical.
SARCASM - Just one more service we offer here.

nottingham82

  • Hero Member
  • *****
  • Posts: 1746
    • View Profile
Re: Stepper motor problem
« Reply #1 on: September 04, 2018, 07:14:42 PM »
maybe the y driver is failing? it can supply enough power for 1 stepper but not 2? have you tried pulling the driver off swapping it with the x and readjusting for y voltage and seeing if that changes anything?
Laser: 2500mw A5 eleks maker
OS: Windows 10 all in one pc
Software: T2
http://www.gearbest.com/3d-printers-3d-printer-kits/pp_290386.html Paid $160 in 2016

ggallant571

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2469
    • View Profile
Re: Stepper motor problem
« Reply #2 on: September 05, 2018, 06:12:11 AM »
Yes - i swapped the driver boards and reset the current limits. Away for a couple of days but next experiment will be to loosen the drive gear or remove the belt.
SARCASM - Just one more service we offer here.

ggallant571

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2469
    • View Profile
Re: Stepper motor problem
« Reply #3 on: September 07, 2018, 12:44:13 PM »
Turned out the problem was a broken wire. Added to the confusion was the "new" stepper driver cables have different pin mappings. Took 3 new cables and mapped the pins (colors did not match) to the originals and it is now working fine. BTW - I have 2 other sets of cables and neither matches the original. Time to add some cable support brackets near the controller.
SARCASM - Just one more service we offer here.

ThothLoki

  • Hero Member
  • *****
  • Posts: 2129
  • Tinkerer
    • View Profile
Re: Stepper motor problem
« Reply #4 on: September 07, 2018, 03:06:52 PM »
https://www.thingiverse.com/thing:2411247

This and a zip tie really helped me
Laser: A5 2000mw with L7 Board / A3 2500mw PWM with Mana SE -- All using T2Laser
3D Printer: Monoprice Maker Select v2.1
Image Resizer Applications (All OS): http://benboxlaser.us/index.php/topic,1434.msg17297.html#msg17297

ggallant571

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2469
    • View Profile
Re: Stepper motor problem
« Reply #5 on: September 07, 2018, 03:51:43 PM »
Thanks.
SARCASM - Just one more service we offer here.