Author Topic: Trace picture, cant get outline smooth  (Read 690 times)

amerikkaan

  • Newbie
  • *
  • Posts: 6
    • View Profile
Trace picture, cant get outline smooth
« on: November 29, 2018, 12:52:03 AM »
Hi,

bought the chinese 2500mw laser and I have played with it some time now. I thought benbox was ok, but decided to go for T2 to get more out of it.
Now I noticed, if I trace an image to burn the outlines, I just can't get the line smooth. Closer inspection seems like the burn line is not constant but like dotted or intermittent and also uneven.
Here's a link of two photos I took, picture engraved is the same in both and outline traced. Only difference the first made with benbox and last with T2. The difference in quality is noticable.
Could someone help me on what I'm doing wrong?

https://photos.app.goo.gl/16VyQZzqAz4qQfHm8

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6941
    • View Profile
    • T2Laser
Re: Trace picture, cant get outline smooth
« Reply #1 on: November 29, 2018, 08:51:23 AM »
I don't think this is related to tracing, are you using my Grbl 1.1e DEFAULT firmware?

amerikkaan

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Trace picture, cant get outline smooth
« Reply #2 on: November 29, 2018, 10:29:05 AM »
Hi, yes I'm using the default firmware, I bought Laser shield v1.2 controller board and noticed there was grbl 1.1f but I flashed the default firmware.

amerikkaan

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Trace picture, cant get outline smooth
« Reply #3 on: November 29, 2018, 12:23:04 PM »
Did some testing with basic text and the lines come pretty ok, but the line is not constant. It's like the laser "blinks" rapidly instead of being on, or thats how I would describe it, as you can clearly see it's not smooth.

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6941
    • View Profile
    • T2Laser
Re: Trace picture, cant get outline smooth
« Reply #4 on: November 29, 2018, 04:44:26 PM »
The only reason it would do that is if laser mode wasn’t enabled, which is why I asked if you were using my firmware. Is it possibly you’ve used other software and my parameters were changed?

Check that laser mode is enabled, or use either Reset Grbl Parameters or Load Default Parameters.

ggallant571

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2984
    • View Profile
Re: Trace picture, cant get outline smooth
« Reply #5 on: November 29, 2018, 07:37:34 PM »
You might want to start with a "known" test pattern to verify the basic machine operation.  No tracing, just a black/white raster image with clean edges.
SARCASM - Just one more service we offer here.

amerikkaan

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Trace picture, cant get outline smooth
« Reply #6 on: November 29, 2018, 10:55:00 PM »
I checked and laser mode is on, heres the parameters:

Connected COM6 115200
Grbl 1.1e Ready
$0=10 Step pulse, microseconds (10)
$1=25 Step idle delay, milliseconds (25)
$2=0 Step port invert, mask (0)
$3=3 Direction port invert, mask (0)
$4=0 Step enable invert, boolean (0)
$5=0 Limit pins invert, boolean (0)
$6=0 Probe pin invert, boolean (0)
$10=3 Status report, mask (1)
$11=0.020 Junction deviation, mm (0.020)
$12=0.020 Arc tolerance, mm (0.020)
$13=0 Report inches, boolean (0)
$20=0 Soft limits, boolean (0)
$21=0 Hard limits, boolean (0)
$22=0 Homing cycle, boolean (0)
$23=3 Homing dir invert, mask (0)
$24=100.000 Homing feed, mm/min (100.000)
$25=1000.000 Homing seek, mm/min (1000.000)
$26=250 Homing debounce, milliseconds (250)
$27=1.000 Homing pull-off, mm (1.000)
$30=255 Max spindle speed, RPM (255)
$31=0 Min spindle speed, RPM (0)
$32=1 Laser mode, boolean (1)
$100=80.000 X steps/mm (80.000)
$101=80.000 Y steps/mm (80.000)
$102=80.000 Z steps/mm (80.000)
$110=5000.000 X Max rate, mm/min (5000.000)
$111=5000.000 Y Max rate, mm/min (5000.000)
$112=5000.000 Z Max rate, mm/min (5000.000)
$120=800.000 X Acceleration, mm/sec^2 (800.000)
$121=800.000 Y Acceleration, mm/sec^2 (800.000)
$122=5000.000 Z Acceleration, mm/sec^2 (5000.000)
$130=400.000 X Max travel, mm (400)
$131=300.000 Y Max travel, mm (300)
$132=200.000 Z Max travel, mm (200)

ggallant571 I'll do some more testing later today with raster image.
« Last Edit: November 29, 2018, 10:57:46 PM by amerikkaan »

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6941
    • View Profile
    • T2Laser
Re: Trace picture, cant get outline smooth
« Reply #7 on: November 30, 2018, 04:26:50 AM »
On the laser control screen, enable Reduced Acceleration in the Settings / Advanced menu. If that helps then it's likely a mechanical issue.

amerikkaan

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Trace picture, cant get outline smooth
« Reply #8 on: November 30, 2018, 06:53:15 AM »
Tested simple raster ball, b&w speed 1000, laser power 150 and ticked the "reduced acceleration" on.

https://photos.app.goo.gl/1AtvCTg1onzPcoPm7

ggallant571

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2984
    • View Profile
Re: Trace picture, cant get outline smooth
« Reply #9 on: November 30, 2018, 10:43:27 AM »
Attached is my goto test pattern.
SARCASM - Just one more service we offer here.

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6941
    • View Profile
    • T2Laser
Re: Trace picture, cant get outline smooth
« Reply #10 on: November 30, 2018, 05:27:37 PM »
I can't tell from the picture if there's an issue or not, what is your conclusion?

amerikkaan

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Trace picture, cant get outline smooth
« Reply #11 on: December 01, 2018, 05:48:45 AM »
I checked the hardware and adjusted some of the loose fittings and bearings. Also moved the laser head to the corner and did some testing. I think it's works bit better now. My rig is so big, print area is 100cmx100cm so if I engrave picture in the center, the rig itself gives in a bit as the axel "bars" are so long.
Going to do more testing and burning but it seems to be working ok now. Thank you guys for all your help!! Can you point out where I could purchase better wheels for the assembly? I have the white pom wheels and they arent wery accurately made (chinese cheap quality).

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6941
    • View Profile
    • T2Laser
Re: Trace picture, cant get outline smooth
« Reply #12 on: December 01, 2018, 09:32:13 AM »
Benbox firmware motion is much slower and has less aggressive acceleration so you don't see mechanical problems as much, because Grbl 0.9 and 1.1 made improvements to the smoothness of the steppers it allows faster acceleration and movement which requires a better setup machine.

Of course you can always slow down the acceleration, feed rates or disable bi-directional engraving to improve things but these are band-aids to the actual mechanical issues.

You may want to consider replacing the wheels if they aren't round.