Author Topic: servo problem  (Read 369 times)

ciapski

  • Newbie
  • *
  • Posts: 8
    • View Profile
servo problem
« on: December 11, 2018, 09:33:10 AM »
Hi,
i've got some servo problem with T2laser. I'm on Grbl 1.1f and i can't set the configuration EleksMana to EleksDraw or servo mode. I get an error "error:20". The servo is moving only in one direction and don't come back. Laser power set to 35. The servo model is MG90S.
Can i somehow downgrade to Grbl 1.1e?

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6397
    • View Profile
    • T2Laser
Re: servo problem
« Reply #1 on: December 11, 2018, 09:39:02 AM »
You must use the Eleks Mana firmware (in the custom firmware menu) for the EleksDraw, it is a CoreXY machine that needs servo support.

Then you configure it in the menu as you are trying to do.

ciapski

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: servo problem
« Reply #2 on: December 11, 2018, 10:42:56 AM »
i didn't mention, i've got the Elekslaser A3 with attached servo.
Did i do everything alright or should i try with your settings?

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6397
    • View Profile
    • T2Laser
Re: servo problem
« Reply #3 on: December 11, 2018, 11:26:22 AM »
If you are using a servo, you'll need the Eleks Mana firmware and then configure it in the menu (click EleksLaser E1 and then Servo Mode A1).

ciapski

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: servo problem
« Reply #4 on: December 12, 2018, 01:45:27 AM »
Ok but as i wrote in the first post  when i try it i get an error "error:20"

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6397
    • View Profile
    • T2Laser
Re: servo problem
« Reply #5 on: December 12, 2018, 04:27:44 AM »
You said you were using 1.1f which is incorrect, Eleks Mana is 0.9i and the only one which supports both CoreXY and Servo modes. Grbl 1.1 is too large to fit the Nano memory with these enabled.

ciapski

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: servo problem
« Reply #6 on: December 12, 2018, 11:38:10 PM »
Is it any way to downgrade to 0.9?

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6397
    • View Profile
    • T2Laser
Re: servo problem
« Reply #7 on: December 13, 2018, 04:39:14 AM »
You just select the firmware in the menu, the process is no different to flashing any firmware.

ciapski

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: servo problem
« Reply #8 on: December 18, 2018, 05:25:33 AM »
Ok, my bootloader is broken. That's why i can't flash the firmaware. I'll try to burn it with another nano.

ciapski

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: servo problem
« Reply #9 on: December 27, 2018, 04:00:36 AM »
So i've got a new arduino and uploaded 0.9i firmware, set the Servo Mode and its working. Thanks.
But with this firmware homing the machine doesn't work. It just saing "Homing .." and nothing happens.

ggallant571

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2531
    • View Profile
Re: servo problem
« Reply #10 on: December 27, 2018, 07:19:30 AM »
Did you build the firmware with the homing features enabled?
Do you have the runtime parameters set?
Does your host software issue the grbl $H command?
« Last Edit: December 27, 2018, 07:21:30 AM by ggallant571 »
SARCASM - Just one more service we offer here.

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6397
    • View Profile
    • T2Laser
Re: servo problem
« Reply #11 on: December 28, 2018, 08:57:41 AM »
Since you arenít using a CoreXY machine it would be possible to build 1.1 w/servo support and include homing.

ciapski

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: servo problem
« Reply #12 on: January 03, 2019, 02:11:37 AM »
I'm using the build in firmware from Zax. So if you could build one with servo and homing it would be great.

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6397
    • View Profile
    • T2Laser
Re: servo problem
« Reply #13 on: January 03, 2019, 04:49:15 AM »
The problem is I don't have a machine with your configuration.

Do you know how to compile Grbl? If you grab the 1.1f w/servo code and set the homing how you prefer that should be all that's required.

ciapski

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: servo problem
« Reply #14 on: January 04, 2019, 05:10:05 AM »
the problem is that the EleksLaser is on an Arduino Nano? And there is not enough memory?
Zax can you help me with that compilation. I don't now how to do it but if you can share some sites where to learn it i can try.