Author Topic: Stepper binding with specific T2 command  (Read 236 times)

KwisatzHaderach

  • Newbie
  • *
  • Posts: 3
    • View Profile
Stepper binding with specific T2 command
« on: April 30, 2019, 04:47:35 PM »
I am trying set $100 in T2.

Currently have it set at $100=800.  When I use "Control Laser" to move the stepper it binds with 20 and 50 movements.

Youtube Video https://youtu.be/C8CAhubnPQc

This happens with G91G00X50F2000, G91G00X-50F2000, and sometimes with G91G00X20F2000, G91G00X-20F2000

This does not happen when I send G1 X50 F2000, I have even manually sent G1 X50 F2500 without issue.

This binding happened on 20 and 50 when the current was set at .4  The current is currently set at .9

This also does not happen at with $100=400.00
« Last Edit: April 30, 2019, 04:55:19 PM by KwisatzHaderach »

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6805
    • View Profile
    • T2Laser
Re: Stepper binding with specific T2 command
« Reply #1 on: April 30, 2019, 04:55:29 PM »
$100 is the steps per mm for X-axis, it should be 80 for most laser machines.

G0 is a rapid move so ignores the feed rate, it uses $110. So lower that to 2500 and G0 will act like the G1 command you say works. The default is 4000 which on most machines won't cause a problem.

You may need to adjust the acceleration, in the settings menu you can select Reduced Acceleration.

KwisatzHaderach

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Stepper binding with specific T2 command
« Reply #2 on: April 30, 2019, 05:16:45 PM »
$100 is the steps per mm for X-axis, it should be 80 for most laser machines.

G0 is a rapid move so ignores the feed rate, it uses $110. So lower that to 2500 and G0 will act like the G1 command you say works. The default is 4000 which on most machines won't cause a problem.

You may need to adjust the acceleration, in the settings menu you can select Reduced Acceleration.

Thank you for the prompt reply.   I am testing what will be the Z axis, I have a mana SE board I connected it to on the X axis, which I why I am adjusting the $100.  I am trying to get the information tested before I connect to my 3 axis mana board.

Will do on the $110


More on $100.    When I set $100=400 and move 20mm the measured movement is 10mm. I set it t0 $100=800 and when I move 20mm the measured movement is 20mm. So I am using this extra board to figure out what I need to set the Z at in my other board.

« Last Edit: April 30, 2019, 05:18:45 PM by KwisatzHaderach »

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6805
    • View Profile
    • T2Laser
Re: Stepper binding with specific T2 command
« Reply #3 on: April 30, 2019, 06:13:57 PM »
It's going to depend on the gearing for the axis, you can easily calibrate it from the menu in T2Laser.

When it's set to 400 your feed rate is actually half so that's why it doesn't stall, reduce the acceleration ($122) and max feed rate ($112) for the Z axis.

I would suggest:
$112=2000
$122=200

(or since you are testing with the X it would be $110 & $120)

ggallant571

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2913
    • View Profile
Re: Stepper binding with specific T2 command
« Reply #4 on: April 30, 2019, 07:15:40 PM »
The stepper motor driver may have more micro steps than the typical A4988.
SARCASM - Just one more service we offer here.