Author Topic: Laser weak works but no engraving  (Read 153 times)

ediazf

  • Newbie
  • *
  • Posts: 11
    • View Profile
Laser weak works but no engraving
« on: June 14, 2020, 06:12:35 PM »
Hi guys!  My laser cable broke this morning and I didn't have a replacement cable. Stupidly I cut the wires and went directly into soldering without looking how it was setup to begin with.

I solder both ends the same and apparently they had to be Crossed (black on the middle, and yellow on the pin1 on one end and on pin3 on the other end. The thing is that I corrected de cable and now when I press the laser.button, weak laser.comes on normally but when I engrave something with the software, laser doesnt come up. Moves, etc, but no full power laser comes on.

I tried restarting the PC, the machine. Resetting rom, etc. Nothing works. 12volt line is working but the other (I think it's 5v isn't it?) doesn't give voltage at any time. Not when engraving, not when idle, not when elekscam LASER ON button is on.

Any help? When I connected the wire backwards the first te maybe I threw 12v into a 5v line and burned it? Is that fixable? Please.help!!!

Thanks!

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7154
    • View Profile
    • T2Laser
Re: Laser weak works but no engraving
« Reply #1 on: June 15, 2020, 03:47:00 AM »
It sounds like you overloaded the TTL input, everything is fixable but without knowing the circuit it's going to take some guess work and a meter to figire out how to repair it.

ediazf

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Laser weak works but no engraving
« Reply #2 on: June 15, 2020, 05:25:54 AM »
It sounds like you overloaded the TTL input, everything is fixable but without knowing the circuit it's going to take some guess work and a meter to figire out how to repair it.

Sorry for my ignorance... The TTL input is the board that's on the laser module itself?  I have a meter, what should.I look for? Resistance.of.the components?

Please help I need this machine for work!!  Thanks man!

ediazf

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Laser weak works but no engraving
« Reply #3 on: June 15, 2020, 05:34:53 AM »
It sounds like you overloaded the TTL input, everything is fixable but without knowing the circuit it's going to take some guess work and a meter to figire out how to repair it.

Just to help you help me  ;D , if the TTL input is actually the board that's on top the laser itself (Wich is what I would have guessed because of the fact that the improper 12v I feed to some circuit is on that board) howcome the meter doesn't register any voltaje coming out of the 5v output from the Mana SE board?

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7154
    • View Profile
    • T2Laser
Re: Laser weak works but no engraving
« Reply #4 on: June 15, 2020, 05:54:40 AM »
If you disconnect the laser from the Mana board you should see a voltage signal on the S pin (which is D11, the TTL/PWM to the laser driver).

If not, remove the Nano from the board and carefully check the D11 output to GND.

The signal should be >3.5V when the laser output is on (at full power) and <0.7V when it is off.

ediazf

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Laser weak works but no engraving
« Reply #5 on: June 15, 2020, 11:34:27 AM »
If you disconnect the laser from the Mana board you should see a voltage signal on the S pin (which is D11, the TTL/PWM to the laser driver).

If not, remove the Nano from the board and carefully check the D11 output to GND.

The signal should be >3.5V when the laser output is on (at full power) and <0.7V when it is off.

Tried the voltages you asked me. My meter does not read decimals, so 1volt increments.

When the laser module is disconnected from the Mana SE board, 12v (+ and -) does give 12v and the other, (- and S) gives between 4 to 5 volts  when full power and 0 volts when off (I am assuming it could be less than 0.5v and my meter just doesn't register.

When I plug the laser module, 12v still going but S goes to 0

ediazf

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Laser weak works but no engraving
« Reply #6 on: June 15, 2020, 05:56:25 PM »
What I did was to cut two stepper motor cables. Each one had one end that had the kind of pins that would enter the laser plastic male connector. So I removed the stepper motor pins from the plastic conector, inserted the black/red/yellow cables into each of the original laser module plastic male connector and soldered them.  Besides the fact that initially I messed up the layout, the cable is soldered right and meter confirms each one is fine. So, the homemade makeshift cable shouldn't be the problem...  🥺🤓

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7154
    • View Profile
    • T2Laser
Re: Laser weak works but no engraving
« Reply #7 on: June 16, 2020, 03:44:15 AM »
The laser driver TTL input has a short, which isn't surprising given that you connected 12V to the TTL.

ediazf

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Laser weak works but no engraving
« Reply #8 on: June 16, 2020, 06:28:49 AM »
The laser driver TTL input has a short, which isn't surprising given that you connected 12V to the TTL.

Any fix or is it better to just buy a new laser module?
Something like this?

In your experience, a 500mw engrave a less deep black than the 2500mw at the same speed? Or maybe buy the 500mw and use it's board (the thing on top with the fan, etc) and replace the one I shorted with the 2500mw module I already have?

Thank you man!!!  Really appreciate it!!


Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7154
    • View Profile
    • T2Laser
Re: Laser weak works but no engraving
« Reply #9 on: June 16, 2020, 06:50:27 AM »
If you need to ask how to fix it, you should probably buy a replacement module.

I would recommend a 2500mW for general engraving. You can't swap the driver boards over, well not between different power diodes without current adjustments. If you got a new 2500mW and later the diode fails you could use that driver board on the old module.

ediazf

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Laser weak works but no engraving
« Reply #10 on: June 16, 2020, 11:29:01 AM »
If you need to ask how to fix it, you should probably buy a replacement module.

I would recommend a 2500mW for general engraving. You can't swap the driver boards over, well not between different power diodes without current adjustments. If you got a new 2500mW and later the diode fails you could use that driver board on the old module.

Banggood isn't shipping to my country yet. Do you know other place to buy online? Any spare part I can buy you?  🙏🙏🙏

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7154
    • View Profile
    • T2Laser
Re: Laser weak works but no engraving
« Reply #11 on: June 16, 2020, 12:13:27 PM »
You could try Aliexpress or an auction site similar to ebay but there are many poor quality laser modules so look for a genuine Eleksmaker if possible.

ediazf

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Laser weak works but no engraving
« Reply #12 on: June 16, 2020, 06:20:26 PM »
You could try Aliexpress or an auction site similar to ebay but there are many poor quality laser modules so look for a genuine Eleksmaker if possible.

found this one that ships to Chile... https://www.ebay.com/itm/333315961705

hopefully it works until things go back to kind of normal so banggood ships to chile again...