Author Topic: Stepper motor weird noise. Like stuck.  (Read 131 times)

ediazf

  • Newbie
  • *
  • Posts: 16
    • View Profile
Stepper motor weird noise. Like stuck.
« on: September 13, 2020, 10:43:13 PM »
Hey guys, one of my stepper motors is making that noise when the laser gets to an end of the board but it still tries to keep going. Lime the motor is stuck but trying to keep going (I don't know if I am making any sense haha).


When I move the laser 100 mm it sounds weird, like it struggles, but when I free hand it, I don't feel any resistance.

Also, when engraving, while it is moving continusly, sounds and work normal but when it finishes a part of the imagen and moves quickly to another part to start again, it sounds weird again and sometimes it skip a couple of steps and mess out the whole engrave.

Any help? Any recommendation on making my steppers a maintenance?  It is not the cable, I tried other ones, tried the supposedly faulty one on other stepper and works fine...

ggallant571

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3197
    • View Profile
Re: Stepper motor weird noise. Like stuck.
« Reply #1 on: September 14, 2020, 10:35:02 AM »
Stepper motor driver chips typically have a max current adjust. Set too high and the motors can overheat. Set too low and the motors can stall.

Does you problem occur everywhere or at specific points? Does it loose position or recover? Does it happen with and without laser working? Suggest you generate a test pattern that demonstrates the problem at its worse.
SARCASM - Just one more service we offer here.