Author Topic: Shows "Connected" but not "Grbl Ready"  (Read 1002 times)

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6815
    • View Profile
    • T2Laser
Shows "Connected" but not "Grbl Ready"
« on: October 20, 2016, 05:14:11 AM »
This means the COM port was opened but Grbl isn't responding.

I was able to flash the firmware, but still couldn't connect. I tried another cable, same thing.

I went to Device Manager and saw it had a generic COM port in the Ports section, but there was also a "USB 2.0 Serial" listed under Other devices.

I clicked on it and selected to update driver, chose search automatically and waited. After a few seconds it started to update the driver and on completion it showed USB-SERIAL CH340 was updated successfully and now it appears correctly in the Ports (COM & LPT) section and is gone from Other devices, but more importantly, it works!

I'm guessing that Windows initially installed a generic driver that wasn't fully compatible. I also had to re-scan the COM ports and select the new one that showed up as a different COM port number.




kn4ud

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 753
    • View Profile
Re: Shows "Connected" but not "Grbl Ready"
« Reply #1 on: October 20, 2016, 06:00:41 AM »
Good Information Zax, This should be put in a FAQ section on this site for future reference to others.
Allen

beikeland

  • Guest
Re: Shows "Connected" but not "Grbl Ready"
« Reply #2 on: October 20, 2016, 06:32:46 AM »
On windows everything will get different COM port numbers if you move it around to different ports, or connect things in varying orders. FTDI chips are quite good at maintaing the COM port number for a given serial converter, but its not perfect.