Author Topic: Zero point burn...revisited  (Read 981 times)

mauriceman

  • Jr. Member
  • **
  • Posts: 99
    • View Profile
Zero point burn...revisited
« on: October 27, 2016, 01:11:33 PM »
Greetings, a newbie here.

First of all I would like to thank Zax for an intuitive GUI that controls my laser very nicely. It takes my vector drawings from Inkscape and interprets them very well. Coming from Photoshop and Illustrator, Inkscape is quite the learning curve. How many times have I hit CTRL-0 and nothing happened. Thanks to all the other contributors helping out as this new hobby matures. I enjoy reading all the posts.

Zax, I take it the newest version 1.3j still installs the j-tech firmware as default and the newer GRBL 1.1c is included for experimenting via external flashing.

Something I found. I have one of those 2.5W Banggood lasers that doesn't work with TTL so I purchased a 2W with external TTL board from China. Too bad it wasn't the same physical size. Today I finally fired it up and, like another person noticed, when you go to the laser screen in T2LASER, the laser fires full tilt for several seconds. Turns out the TTL board that came with the laser has a 10K pull-up resistor on it and it appears to me the PWM pin on the Arduino goes high impedence between the main and the laser screen (clicking on the USB icon). The TTL threshold on my TTL board is about 1.2V, so I added a 2K resistor in parallel with the TTL input and now no more unwanted bright flashes of light. I tried different versions of T2LASER and reinstalled the J-TECH firmware and default parameters to no avail before adding the pull-down resistor.

The 2W laser I bought is all over the auction sites. It's the one where the TTL board is on a heatsink with it's own fan. Oh yes, and very short wires. It's the one with the warning "TTL Modulation: Make sure input TTL level PWM dightal signal" (copied verbatum), for without the TTL connected, the laser is ON.

Thanks again
Retired Industrial Electrician, PLC
500mmX500mm Openbuilds frame
1.6w, 2w, 2.5w laser heads

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6792
    • View Profile
    • T2Laser
Re: Zero point burn...revisited
« Reply #1 on: October 27, 2016, 04:00:48 PM »
Thank you for the kind words and information.

I have the 2000mW TTL module from Banggood and it doesn't have that issue, although now I think about it, I probably don't turn it on until I'm in the laser control screen. That's when T2Laser connects to Grbl, so perhaps it's something happening at boot up since others reported 1.1c doesn't do it.

J-Tech has several known bugs and lacks support for certain features. The latest version can install 1.1c (which I compiled with my settings) or J-Tech, I'm using 1.1c now because I added limit/home switches and so far haven't had any issues. In fact I'm almost to the point of just recommending it for use with T2Laser.