Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - mattm58

Pages: [1] 2 3 4
1
T2 Engraving / Re: firmware for core-xy
« on: June 16, 2020, 02:25:43 PM »
Thanks, knew it was probably a simple fix, just couldn't figure out where...  :)

2
T2 Engraving / Re: firmware for core-xy
« on: June 16, 2020, 01:26:47 PM »
Hey Zax, got another question.  Haven't been able to screw with the firmware & arduinos for a while, life got in the way.  I do have a new oddity.  Now, on the core-xy machine any time I bring up the laser control screen it auto sets current position to x:0, y:15, z:0.  It used to set all three to 0, so obviously something happened along the way, but I can't figure out what.  How do I set this back so it auto sets current position to 0:0:0?  This has screwed me up several times because I started the engraving where it was at and Y was off by 15...


3
T2 Engraving / Re: firmware for core-xy
« on: June 01, 2020, 03:22:47 PM »
Alright guys, getting back to attempting to update the bootloader on the two  non working nanos.  Got a borrowed nano flashed with the ISP code, then realized none of the nanos on my eleksmaker controllers have the iscp pinouts.  How do you program these, or is it time to toss these and pick up some new ones with iscp pins?

4
T2 Engraving / Re: firmware for core-xy
« on: May 27, 2020, 01:04:59 AM »
Success!  First test, a coaster for a friend, is attached.

Speed is definitely off.  @ggallant571, I think you're right, looks close to square root of 2 off.  I'll look at the code tomorrow and see if I can make a simple fix.

5
T2 Engraving / Re: firmware for core-xy
« on: May 26, 2020, 04:57:13 PM »
Ok, fingers crossed, I *think* I may have it working!  At least it is jogging around and pulse/power on-power off.

@zax - please let me know if anything I've commented out needs to be put back in for t2 to work correctly.  I don't plan on doing any flashing of firmware from t2 on this one now.

From the default grbl 1.1h I had to do the following:

enable core-xy (uncomment the #define)

Comment out the following to free up enough space:

//#define REPORT_FIELD_BUFFER_STATE // Default enabled. Comment to disable.
//#define REPORT_FIELD_PIN_STATE // Default enabled. Comment to disable.
//#define REPORT_FIELD_OVERRIDES // Default enabled. Comment to disable.
//#define REPORT_FIELD_LINE_NUMBERS // Default enabled. Comment to disable.

//#define ENABLE_RESTORE_EEPROM_WIPE_ALL         // '$RST=*' Default enabled. Comment to disable.
//#define ENABLE_RESTORE_EEPROM_DEFAULT_SETTINGS // '$RST=$' Default enabled. Comment to disable.
//#define ENABLE_RESTORE_EEPROM_CLEAR_PARAMETERS // '$RST=#' Default enabled. Comment to disable.
//#define ENABLE_BUILD_INFO_WRITE_COMMAND // '$I=' Default enabled. Comment to disable.
//#define FORCE_BUFFER_SYNC_DURING_EEPROM_WRITE // Default enabled. Comment to disable.
//#define FORCE_BUFFER_SYNC_DURING_WCO_CHANGE // Default enabled. Comment to disable.


@ggallant571 - I do plan on picking up another few arduinos so I can make an ISP to flash a 'modern' bootloader to hopefully gain space back and not have to disable all the above.  When you said speed was off, was that in the physical speed it was running at, estimated time remaining it t2, ?  Was it higher or lower?



6
T2 Engraving / Re: firmware for core-xy
« on: May 26, 2020, 03:55:33 PM »
I did this one:  https://www.thingiverse.com/thing:3016513

Modified a couple of the plates to add mounts for drag chain.  It started as a standard a3 frame, then I swapped out the Y rails for 1m rails.  I've got two of these exactly the same.  One I have no issues, the other I've spent a LOT of time trying to figure out various issues, I think it boils down to the two Y steppers not staying in sync.  It works great for small items, but when I get further up the Y axis it starts to distort.  I figured if I was redoing things anyway I'd try the core-xy setup that eliminates a stepper.  Obviously don't have it running yet to have any results...

7
T2 Engraving / Re: firmware for core-xy
« on: May 26, 2020, 03:02:01 PM »
Old bootloader, it's the only one I can get an upload to work with.

Through screwing around I've managed to get everything working except for resetting the home position the t2 laser control screen.  I'm sure it probably uses one of the optional report fields I commented out to get it small enough. 

8
T2 Engraving / Re: firmware for core-xy
« on: May 26, 2020, 12:54:04 PM »
Ok, managed to get arduino ide installed, downloaded grbl, was able to compile and upload the example grblUpload.  If I enable core-xy the sketch is too big.  What should I comment out in the config.h file to get it back under size to fit on the nano?

9
T2 Engraving / Re: firmware for core-xy
« on: May 25, 2020, 10:06:58 PM »
Alright, I'm new to all this arduino programming/flashing/etc.  The most I've done is flash the grbl version using T2.

I've got three nanos now that won't flash.  One good one, but I don't want to pull it from the other, working, laser and bork it too.

That being said, what do I need to do to get a working core-xy firmware flashed to a nano?  The 0.9i doesn't seem to work for me, as mentioned above once I turn the laser on it doesn't turn off.  All core-xy movements are good though.  It sounds like I need to move to 1.1, but that doesn't fit with the old bootloader?

Buy more nanos?  Buy a programmer?  I really have no idea what I'm doing here, as you can probably tell...

If the simplest option is to buy a programmer, any suggestions?  It looks like programming using arduino isp requres an uno and not a nano?

Thanks for all your help guys!

10
T2 Engraving / Re: firmware for core-xy
« on: May 25, 2020, 05:44:20 PM »
Homing was a little challenge. I have the X limit switch on the lower left and the Y limit switch on the lower right. Perform the Y first and then the X. This also required entries in the parameters section. No problem sharing the hex. Will do a dump of parameters and post both and the config file.

Thanks @ggallant571

I've tried flashing your firmware twice with avrdude, but both times I get to 97% writing and then get a "programmer is not responding" error.  At this point I've only got one working nano left and don't want to hose it. 

The working nano is running 0.9i.  All axis movements are correct, but if I try to pulse the laser or turn on/off via the laser control screen the laser comes on but I can't turn it off.  the off button doesn't do anything, and the pulse turns it on and it stays on.  Any ideas?

11
T2 Engraving / Re: firmware for core-xy
« on: May 21, 2020, 10:52:03 PM »
I've been using grbl-1.1f for some time now with core-xy etchers. Need to build with the core-xy feature enabled.

Would you be willing to share the hex file so I don't have to figure out how to compile it?   ;D

12
T2 Engraving / Re: firmware for core-xy
« on: May 21, 2020, 04:13:42 PM »
Nevermnid, managed to get it working using 0.9i with eleckscam software setting grbl params.  For anybody else who looks for this in the future, here's my grbl settings:

Connected COM3 115200
Grbl Ready
Origin Set (Home)
$$
$0=10 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=1 (dir port invert mask:00000001)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.010 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=100.000 (x, step/mm)
$101=100.000 (y, step/mm)
$102=400.000 (z, step/mm)
$110=5000.000 (x max rate, mm/min)
$111=5000.000 (y max rate, mm/min)
$112=5000.000 (z max rate, mm/min)
$120=200.000 (x accel, mm/sec^2)
$121=200.000 (y accel, mm/sec^2)
$122=200.000 (z accel, mm/sec^2)
$130=5000.000 (x max travel, mm)
$131=5000.000 (y max travel, mm)
$132=5000.000 (z max travel, mm)

13
T2 Engraving / firmware for core-xy
« on: May 21, 2020, 03:19:59 PM »
Hey @zax, I've rebuilt one of my eleks a3 frames as a core-xy machine.  Do any of the firmware options built into T2 operate as a core-xy?  I tried the 1.1f CNC Z-XY firmware, but x directionals go diagonal and Y & diagonal seem to have the two steppers fighting against each other.  I've also tried the 0.9i as mentioned on one of the other posts and tried a bunch of the options in configuring the eleks mana, but no dice...

14
T2 Engraving / Re: overscan/dynamic laser power/dark edges
« on: October 25, 2019, 12:45:56 PM »
Will do, thanks Zax! 

15
T2 Engraving / Re: overscan/dynamic laser power/dark edges
« on: October 25, 2019, 10:34:45 AM »
Ok, box in upper right is after setting $120 and $121 to 1200 (were 200), overscan, dynamic power, bi-directional all on.  All other GRBL settings were what you listed.  I am burning at a power of 80 (speed 4000) so you can see the difference, at full power it would just be a black box of char.

Pages: [1] 2 3 4