Author Topic: Atmega 2560 compile problem  (Read 2166 times)

PD0RUZ

  • Full Member
  • ***
  • Posts: 123
  • Let there be light, LASER LIGHT!
    • View Profile
Atmega 2560 compile problem
« on: December 11, 2016, 01:55:22 AM »
Can somebody tel me how to load the library's for the 2560 to the arduino loader/editor.
Want to try this, but theres no sketch inside the source..
Thanks
*A3 Laser 2500mW
*T2Laser Licensed software*
*Modified 2.5Watt laser module*
*Running Agastar Linear Pwm laser board*
*Co2 Laser 40W, DSP-X7, Air nozzle, Autofocus, Stepper controlled Z-table*

mauvan

  • Guest
Re: Atmega 2560 compile problem
« Reply #1 on: December 11, 2016, 04:27:51 AM »
Use this one delete or rename old gbrl library load it into your arduino ide via library import select library and load
Sketch of course change you settings first in the .h files


Compile and upload


mauvan

  • Guest
Re: Atmega 2560 compile problem
« Reply #2 on: December 11, 2016, 04:28:39 AM »

PD0RUZ

  • Full Member
  • ***
  • Posts: 123
  • Let there be light, LASER LIGHT!
    • View Profile
Re: Atmega 2560 compile problem
« Reply #3 on: December 11, 2016, 07:07:41 AM »
when i do that, i can only acces build and upload... whats going wrong here??
*A3 Laser 2500mW
*T2Laser Licensed software*
*Modified 2.5Watt laser module*
*Running Agastar Linear Pwm laser board*
*Co2 Laser 40W, DSP-X7, Air nozzle, Autofocus, Stepper controlled Z-table*

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7308
    • View Profile
    • T2Laser
Re: Atmega 2560 compile problem
« Reply #4 on: December 11, 2016, 07:15:13 AM »
I think that's the only option, but in the process it saves the hex.

Just make sure you have verbose mode on otherwise it's difficult to find the temp location where it's saved. You also need to leave Arduino IDE open until you copy the hex as it will release all the temp files on closing.

PD0RUZ

  • Full Member
  • ***
  • Posts: 123
  • Let there be light, LASER LIGHT!
    • View Profile
Re: Atmega 2560 compile problem
« Reply #5 on: December 11, 2016, 07:49:40 AM »
Got it..
Got all the file, but having some error i have to correct...
Gonna give it a try..:)
*A3 Laser 2500mW
*T2Laser Licensed software*
*Modified 2.5Watt laser module*
*Running Agastar Linear Pwm laser board*
*Co2 Laser 40W, DSP-X7, Air nozzle, Autofocus, Stepper controlled Z-table*