Author Topic: T2 not setting correct vector rate in sketch plus now? Update: not broken!  (Read 2152 times)

mattm58

  • Jr. Member
  • **
  • Posts: 58
    • View Profile
This used to work, I believe.  I'd say I was pulling my hair out before figuring this out, but being bald that option went away a while ago...

When saving the g-code, it appears T2 is no longer setting the correct vector rate when using sketch plus to do both raster/vector.  I'm trying to engrave, then cut.  Here's my steps:

Start T2 (version 1.5a Registered)
Open image
Select Sketch Plus (Overlay)
Set Feed Rates (engraving at 2000, vector at 100, rapid at 2500 as example)
Click Trace Image button
Select to outline
Click trace image again
Click Save G-Code
Save it
open g-code
First section (raster) has:

...
( Image2Gcode for Grbl )
...
( Feed Rate   : 2000   )
...
G01 X11.6 Y25.7 M03 S0 F2500
X11.7 M03 S255 F2000
X11.8 Y25.7 M03 S255 F2000
...


Second section (vector) has:

...
( Raster2Vector for Grbl )
...
( Vector Rate   : 100   )
...
G01 X9.6 Y25.2 F2500
M03 S0 F2500
X9.5 Y25.2 M03 S255 F2000                                        <---- This should end in F100, not F2000
X9.4 Y25.7 M03 S255 F2000
...


« Last Edit: October 31, 2017, 05:40:45 PM by mattm58 »
A3 2.5w with longer rails making it ~85cm x 40cm

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7308
    • View Profile
    • T2Laser
Re: T2 not setting correct vector rate in sketch plus now?
« Reply #1 on: October 31, 2017, 03:05:20 PM »
I just tested and it's working as expected.

Do you have some other setting enabled in the DXF Settings that is overriding the feed rate?

Try restoring defaults, then reset your feed rates to see if it clears.




laser_cutter

  • Sr. Member
  • ****
  • Posts: 376
    • View Profile
Re: T2 not setting correct vector rate in sketch plus now?
« Reply #2 on: October 31, 2017, 03:56:06 PM »
Repeated the steps, outcome was correct, vector and raster rates different

Did you UNCHECK link box when setting the feed rates?

mattm58

  • Jr. Member
  • **
  • Posts: 58
    • View Profile
Re: T2 not setting correct vector rate in sketch plus now?
« Reply #3 on: October 31, 2017, 05:40:14 PM »
Ok, something was screwed up somewhere in my settings.  The feed rates were not linked, I couldn't find anything set to override, nothing was set in the dxf settings, but did a restore defaults, retried and it was correct.  Thanks!
A3 2.5w with longer rails making it ~85cm x 40cm

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7308
    • View Profile
    • T2Laser
Not sure of the cause, but glad you fixed it.

nottingham82

  • Hero Member
  • *****
  • Posts: 1774
    • View Profile
oh the old, unplug, restart, hit with a hammer, and it just started working fix.
Laser: 2500mw A5 eleks maker
OS: Windows 10 all in one pc
Software: T2
http://www.gearbest.com/3d-printers-3d-printer-kits/pp_290386.html Paid $160 in 2016

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7308
    • View Profile
    • T2Laser
Re: T2 not setting correct vector rate in sketch plus now? Update: not broken!
« Reply #6 on: November 01, 2017, 04:37:33 AM »
Computers (and Zax) are infallible, so it has to be user error  ;D


OK some part of the above may be fiction... but it's on the interwebs so it must be partly true.
« Last Edit: November 01, 2017, 04:38:21 AM by Zax »