Author Topic: GRBL disappeared - can't reload  (Read 2752 times)

BradleyBob

  • Newbie
  • *
  • Posts: 6
    • View Profile
GRBL disappeared - can't reload
« on: March 27, 2020, 06:13:43 PM »
I have an EleksMaker A3 standard 2.5 laser running T2Laser v1.5y. It has been running very well for a couple of years but yesterday I couldn't get it to engrave. When I press control laser I get the connected to com1 but no grbl1.1e ready. When I press send code it greys out and says 11 lines sent 0 executed and paused. I have tried to reload the firmware but it cannot do it, see below for error. I use the engraver in an area without internet and am wondering if this may be an issue. Also because of lack of internet I haven't done any upgrades since first installation.

I have a spare Mana board and have tried that with same result, also 2 different USB cords and 2 different USB ports on the PC, all with the same result.

Any assistance would be appreciated.

vrdude: Version 6.3, compiled on Feb 17 2016 at 09:25:53
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Users\CCC woodwork\AppData\Local\Apps\2.0\1W2QV7Q6.EPD\QZEW1Z77.ABG\t2la..tion_0000000000000000_0001.0005_0505c03eb44c12a5\resources\avrdude.conf"

         Using Port                    : COM1
         Using Programmer              : stk500v1
         Overriding Baud Rate          : 57600
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x03

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7308
    • View Profile
    • T2Laser
Re: GRBL disappeared - can't reload
« Reply #1 on: March 28, 2020, 03:49:18 AM »
I would check the device driver, my guess is a Windows update has replaced it with a newer driver that is not compatible with your machine.

It must be the driver from provider wch.cn, there should be a roll back option in control panel / device manager which will get you back to the correct driver. 

Hokuro

  • Jr. Member
  • **
  • Posts: 88
    • View Profile
Re: GRBL disappeared - can't reload
« Reply #2 on: March 28, 2020, 02:12:17 PM »
without internet how is it updated?
my english is very bad, please be patient. :)

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7308
    • View Profile
    • T2Laser
Re: GRBL disappeared - can't reload
« Reply #3 on: March 28, 2020, 04:50:53 PM »
without internet how is it updated?

Installed some other software that loaded a different driver.

Since he ruled out the Nano, USB cable and port there's not a lot left.
« Last Edit: March 28, 2020, 04:52:26 PM by Zax »

BradleyBob

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: GRBL disappeared - can't reload
« Reply #4 on: March 28, 2020, 05:39:37 PM »
Thanks Zax, I used the engraver 3 weeks ago and all was good. I can see where the driver was installed in 2018 but looking under USB controllers in device manager I cannot see where it is installed. Is the driver part of your install software? If I reinstall your software will it know that it is licenced?

I haven't installed anything on that PC for over a year as it has a very small disk and won't take the Windows updates, not my PC, owned by the community centre that I do the volunteer work for. I put it back on the net today and it started downloading updates so I took it off again. Is there an updated version of your software I should download to install? Would it be best to uninstall the current version and then install the latest?
Thanks,
Bob

Zax

  • T2Laser
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7308
    • View Profile
    • T2Laser
Re: GRBL disappeared - can't reload
« Reply #5 on: March 29, 2020, 04:07:17 AM »
You can install the driver from the Help menu, however Windows is "smart" and won't replace a newer driver with an older one so if there's already something installed it may not be automatically replaced. You can install manually, after clicking the Install CH340 Driver option in the Help menu you will find a folder in your root directory with the driver files.

It should show a COM port in Device Manager.

BradleyBob

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: GRBL disappeared - can't reload
« Reply #6 on: March 29, 2020, 11:21:37 PM »
Thank you Zax, all OK again. Turns out I had to show hidden ports and when I did that 2 ports with the correct driver appeared. Com1 that I usually used has a Microsoft driver so I am now using Com 3'
Thanks again,
Bob